busybox: busybox-update-config should depend on busybox-configure
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 5 Feb 2013 07:16:01 +0000 (07:16 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 5 Feb 2013 20:38:16 +0000 (21:38 +0100)
Before the config file can be copied, it has to exist.  The
other xxx-update-config targets do this as well.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk

index 9154c08925fd5811bc9ab72390e00fc7a62b6a6e..599e1455388c88399dd3ac2e367a0e0f7ba74fc4 100644 (file)
@@ -223,5 +223,5 @@ busybox-menuconfig busybox-xconfig busybox-gconfig: busybox-patch
        rm -f $(BUSYBOX_DIR)/.stamp_built
        rm -f $(BUSYBOX_DIR)/.stamp_target_installed
 
-busybox-update-config:
+busybox-update-config: busybox-configure
        cp -f $(BUSYBOX_BUILD_CONFIG) $(BUSYBOX_CONFIG_FILE)