Fixup the regex used for iptables so it actually works
authorEric Andersen <andersen@codepoet.org>
Sat, 20 Dec 2003 00:02:13 +0000 (00:02 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 20 Dec 2003 00:02:13 +0000 (00:02 -0000)
make/iptables.mk

index edebaff78bcde59e77bfe18cd85fc80306bb1a6f..56bbf1b27c11172b22b5e85450358cf253f1f282 100644 (file)
@@ -15,9 +15,8 @@ $(IPTABLES_BUILD_DIR)/.unpacked: $(DL_DIR)/$(IPTABLES_SOURCE)
        touch $(IPTABLES_BUILD_DIR)/.unpacked
 
 $(IPTABLES_BUILD_DIR)/.configured: $(IPTABLES_BUILD_DIR)/.unpacked
-       $(SED) "s@shell.*YES.*@shell grep -q '__UCLIBC_HAS_IPV6__.*1' \
-               $(BUILD_DIR)/uClibc/include/bits/uClibc_config.h && \
-               echo YES\), YES\)@;" $(IPTABLES_BUILD_DIR)/Makefile
+       $(SED) "s;\[ -f /usr/include/netinet/ip6.h \];grep -q '__UCLIBC_HAS_IPV6__ 1' \
+               $(BUILD_DIR)/uClibc/include/bits/uClibc_config.h;" $(IPTABLES_BUILD_DIR)/Makefile
        touch  $(IPTABLES_BUILD_DIR)/.configured
 
 $(IPTABLES_BUILD_DIR)/iptables: $(IPTABLES_BUILD_DIR)/.configured