openvpn: Fix paths to external utilities
authorValentine Barshak <gvaxon@gmail.com>
Sun, 30 Sep 2012 10:43:58 +0000 (10:43 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 8 Oct 2012 19:55:23 +0000 (21:55 +0200)
This sets paths to ifconfig, route, netstat and ip
in the target root filesystem.

Otherwise the paths leak from the host and may not
match those on the target.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openvpn/openvpn.mk

index 03eabcf02264100baf4b02d36a9bb04bb0644329..1c6e6ecdfa326a43aed487f4f26f1233d86b12f6 100644 (file)
@@ -6,7 +6,16 @@
 
 OPENVPN_VERSION = 2.2.2
 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small --disable-plugins
+OPENVPN_CONF_OPT = --enable-small --disable-plugins \
+                       --with-ifconfig-path=/sbin/ifconfig \
+                       --with-route-path=/sbin/route \
+                       --with-netstat-path=/bin/netstat
+
+ifeq ($(BR2_PACKAGE_IPROUTE2),y)
+OPENVPN_CONF_OPT += --with-iproute-path=/sbin/ip
+else
+OPENVPN_CONF_OPT += --with-iproute-path=/bin/ip
+endif
 
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
        OPENVPN_DEPENDENCIES += lzo