gcc: remove BR2_GCC_SHARED_LIBGCC option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 8 Jul 2013 15:59:45 +0000 (17:59 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 11 Jul 2013 14:26:52 +0000 (16:26 +0200)
Commit 6b48b4803450 ("add a know to enable/disable building a shared
libgcc"), from october 2006, isn't really as to why a
BR2_GCC_SHARED_LIBGCC option was needed. However, now that gcc has
been converted to the package infrastructure, it causes problems
because the host packages are always being passed --enable-shared
--disable-static, so re-adding --disable-shared on top of that break
things.

Moreover, our tests indicate that both a shared *and* a static version
of libgcc are built, and that linking dynamically and statically a
program that uses libgcc_s gives correct results: dynamically linked
against libgcc_s in the first case, statically linked in the second
case.

Therefore, it appears that this option is no longer necessary, and
removing it has the advantage of fixing the builds of
qemu_mips64_malta_defconfig and qemu_sparc_ss10_defconfig, both of
which had BR2_GCC_SHARED_LIBGCC not enabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gcc/Config.in.host
package/gcc/gcc-final/gcc-final.mk
package/gcc/gcc.mk

index 1b191282d0153064a056e81a7f7a90a73208e437..0836f9f64084372f40b6ada435e849f189815235 100644 (file)
@@ -105,14 +105,6 @@ config BR2_INSTALL_FORTRAN
          Note that it is highly recommended NOT to use gfortran
          from gcc older than 4.2.0
 
-config BR2_GCC_SHARED_LIBGCC
-       bool "Build/install a shared libgcc?"
-       depends on !BR2_PREFER_STATIC_LIB
-       default y
-       depends on !BR2_sparc
-       help
-         Build/install a shared libgcc library
-
 config BR2_GCC_ENABLE_TLS
        bool "Enable compiler tls support" if BR2_TOOLCHAIN_BUILDROOT_UCLIBC
        default y
index f99f1a37895270a3d045d5a296d69c5254fa0911..0db2eaa6dd36962dd550dcb741ab87faae0e8970 100644 (file)
@@ -49,12 +49,6 @@ else
 HOST_GCC_FINAL_CONF_OPT += --disable-libgomp
 endif
 
-ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
-HOST_GCC_FINAL_CONF_OPT += --enable-shared
-else
-HOST_GCC_FINAL_CONF_OPT += --disable-shared
-endif
-
 # End with user-provided options, so that they can override previously
 # defined options.
 HOST_GCC_FINAL_CONF_OPT += \
@@ -99,7 +93,6 @@ HOST_GCC_FINAL_POST_INSTALL_HOOKS += HOST_GCC_FINAL_CREATE_SIMPLE_SYMLINKS
 # Cannot use the HOST_GCC_FINAL_USR_LIBS mechanism below, because we want
 # libgcc_s to be installed in /lib and not /usr/lib. We add +x on
 # libgcc_s to ensure it will be stripped.
-ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
 define HOST_GCC_FINAL_INSTALL_LIBGCC
        -cp -dpf $(HOST_DIR)/usr/$(GNU_TARGET_NAME)/lib*/libgcc_s* \
                $(STAGING_DIR)/lib/
@@ -109,12 +102,11 @@ define HOST_GCC_FINAL_INSTALL_LIBGCC
 endef
 
 HOST_GCC_FINAL_POST_INSTALL_HOOKS += HOST_GCC_FINAL_INSTALL_LIBGCC
-endif
 
 # Handle the installation of libraries in /usr/lib
 HOST_GCC_FINAL_USR_LIBS =
 
-ifeq ($(BR2_GCC_SHARED_LIBGCC)$(BR2_INSTALL_LIBSTDCPP),yy)
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
 HOST_GCC_FINAL_USR_LIBS += libstdc++
 endif
 
index d38629d15e534d9b4eebe1db1c55bc7d26e835a4..8bd65fcd582ff2fffbf52831332210bce61229b2 100644 (file)
@@ -40,7 +40,7 @@ endef
 # Apply patches
 #
 
-ifeq ($(ARCH)-$(BR2_GCC_SHARED_LIBGCC),powerpc-y)
+ifeq ($(ARCH),powerpc)
 ifneq ($(BR2_SOFT_FLOAT),)
 define HOST_GCC_APPLY_POWERPC_PATCH
        support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) powerpc-link-with-math-lib.patch.conditional