package/gst1-plugins-good: add shout2 plugin option
authorArnold Bloemert <abloemert@gmail.com>
Fri, 5 Jul 2019 21:50:38 +0000 (23:50 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 1 Aug 2019 19:10:52 +0000 (21:10 +0200)
Signed-off-by: Arnold Bloemert <abloemert@gmail.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/gstreamer1/gst1-plugins-good/Config.in
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index 433084fd6bb363ddaa76784b7b16ca5af039b0ea..40e21985d90f44d4d990a93423cec83c6cbf18eb 100644 (file)
@@ -300,6 +300,12 @@ comment "qmlgl (qt5) plugin needs an OpenGL-capable Qt5 backend"
        depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
        depends on !BR2_PACKAGE_QT5_GL_AVAILABLE && !BR2_PACKAGE_QT5_VERSION_LATEST
 
+config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_SHOUT2
+       bool "shout2"
+       select BR2_PACKAGE_LIBSHOUT
+       help
+         Elements to send data to an icecast server using libshout2
+
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2
        bool "v4l2"
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # multi planar api
index 829d27a2da8bd81a325010c9b4fd1e84ce6b4425..3c9f0d56051b3e269ad5ce67dd3cd45f8957ebe3 100644 (file)
@@ -25,8 +25,7 @@ GST1_PLUGINS_GOOD_CONF_OPTS = \
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_GOOD_CONF_OPTS += \
        --disable-libdv \
-       --disable-dv1394 \
-       --disable-shout2
+       --disable-dv1394
 
 GST1_PLUGINS_GOOD_DEPENDENCIES = gstreamer1 gst1-plugins-base
 
@@ -343,6 +342,13 @@ else
 GST1_PLUGINS_GOOD_CONF_OPTS += --disable-qt
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_SHOUT2),y)
+GST1_PLUGINS_GOOD_CONF_OPTS += --enable-shout2
+GST1_PLUGINS_GOOD_DEPENDENCIES += libshout
+else
+GST1_PLUGINS_GOOD_CONF_OPTS += --disable-shout2
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += --enable-gst_v4l2
 else