Makefile.autotools.in: add libtool v2.4 support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Mar 2011 19:45:06 +0000 (21:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Mar 2011 19:45:06 +0000 (21:45 +0200)
Packages (like avahi) are now using libtool 2.4, so extend the libtool
handling to support those as well.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in
package/buildroot-libtool-v2.4.patch [new file with mode: 0644]

index d445348d2bcbcd9eb36574debafb3e24fb7a21e0..88a06ea223a359d43b3afc98da6c902b1a51ce30 100644 (file)
@@ -145,6 +145,8 @@ define LIBTOOL_PATCH_HOOK
                                toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
                        elif test $$$${ltmain_version} = "2.2"; then\
                                toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
+                       elif test $$$${ltmain_version} = "2.4"; then\
+                               toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.4.patch; \
                        fi \
                done \
        fi
diff --git a/package/buildroot-libtool-v2.4.patch b/package/buildroot-libtool-v2.4.patch
new file mode 100644 (file)
index 0000000..d82d610
--- /dev/null
@@ -0,0 +1,47 @@
+--- a/ltmain.sh
++++ b/ltmain.sh
+@@ -1416,8 +1416,8 @@
+       # was found and let the user know that the "--tag" command
+       # line option must be used.
+       if test -z "$tagname"; then
+-        func_echo "unable to infer tagged configuration"
+-        func_fatal_error "specify a tag with \`--tag'"
++        func_echo "defaulting to \`CC'"
++        func_echo "if this is not correct, specify a tag with \`--tag'"
+ #     else
+ #       func_verbose "using $tagname tagged configuration"
+       fi
+@@ -2962,8 +2962,11 @@
+         # At present, this check doesn't affect windows .dll's that
+         # are installed into $libdir/../bin (currently, that works fine)
+         # but it's something to keep an eye on.
+-        test "$inst_prefix_dir" = "$destdir" && \
+-          func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
++        #
++        # This breaks install into our staging area.  -PB
++        #
++        # test "$inst_prefix_dir" = "$destdir" && \
++        #   func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
+         if test -n "$inst_prefix_dir"; then
+           # Stick the inst_prefix_dir data into the link command.
+@@ -6683,7 +6686,7 @@
+         *)
+           if test "$installed" = no; then
+             func_append notinst_deplibs " $lib"
+-            need_relink=yes
++            need_relink=no
+           fi
+           ;;
+         esac
+@@ -9257,6 +9260,10 @@
+           # Replace all uninstalled libtool libraries with the installed ones
+           newdependency_libs=
+           for deplib in $dependency_libs; do
++              # Replacing uninstalled with installed can easily break crosscompilation,
++              # since the installed path is generally the wrong architecture.  -CL
++              newdependency_libs="$newdependency_libs $deplib"
++              continue
+             case $deplib in
+             *.la)
+               func_basename "$deplib"