libpthsem: add libpth compatibility option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Jul 2014 20:28:47 +0000 (22:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Jul 2014 21:32:05 +0000 (23:32 +0200)
This commit adds the BR2_PACKAGE_LIBPTHSEM_COMPAT option to the
libpthsem package, in order to enable the compatibility with the pth
library, which is useful to support gnupg2.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpthsem/Config.in
package/libpthsem/libpthsem.mk

index ae1c78f5eaad438a984c25a62b65aa047ab85722..932acecd07bc171e03f822b3ccc33e01b199790e 100644 (file)
@@ -7,3 +7,13 @@ config BR2_PACKAGE_LIBPTHSEM
          version, with support for semaphores added.
 
          http://www.auto.tuwien.ac.at/~mkoegler/pth/
+
+if BR2_PACKAGE_LIBPTHSEM
+
+config BR2_PACKAGE_LIBPTHSEM_COMPAT
+       bool "libpth compatibility"
+       help
+         This option enables the compatibility with the original
+         libpth library.
+
+endif
index dbfab34263013759e129368a97ab1220285b8541..040229edd76e994d9813ed9f5820d3b98ae0e049 100644 (file)
@@ -14,4 +14,11 @@ LIBPTHSEM_INSTALL_STAGING = YES
 LIBPTHSEM_DEPENDENCIES = argp-standalone
 LIBPTHSEM_CONFIG_SCRIPTS = pthsem-config
 
+ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT),y)
+LIBPTHSEM_CONF_OPT += --enable-compat
+LIBPTHSEM_CONFIG_SCRIPTS += pth-config
+else
+LIBPTHSEM_CONF_OPT += --disable-compat
+endif
+
 $(eval $(autotools-package))