projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b367ca3
)
open2300: quote TARGET_{CC,LD}
author
Peter Korsgaard
<jacmet@sunsite.dk>
Fri, 20 Jan 2012 14:49:58 +0000
(15:49 +0100)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Fri, 20 Jan 2012 14:49:58 +0000
(15:49 +0100)
TARGET_CC / TARGET_LD may contain spaces (E.G. when ccache is used), so
ensure they are properly quoted when passed to make.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/open2300/open2300.mk
patch
|
blob
|
history
diff --git
a/package/open2300/open2300.mk
b/package/open2300/open2300.mk
index 450b990514e60519e96614fb504e78cc16713110..59be66f581d989a66b504843efb22259d944c2a8 100644
(file)
--- a/
package/open2300/open2300.mk
+++ b/
package/open2300/open2300.mk
@@
-17,7
+17,7
@@
ifeq ($(BR2_PACKAGE_MYSQL),y)
endif
define OPEN2300_BUILD_CMDS
- $(MAKE) CC=
$(TARGET_CC) LD=$(TARGET_LD)
-C $(@D) $(OPEN2300_BINS)
+ $(MAKE) CC=
"$(TARGET_CC)" LD="$(TARGET_LD)"
-C $(@D) $(OPEN2300_BINS)
endef
define OPEN2300_INSTALL_TARGET_CMDS