nano: fix ncursesw build failure
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 21 Oct 2013 18:29:55 +0000 (15:29 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 22 Oct 2013 21:58:22 +0000 (23:58 +0200)
After the latest version bump ncursesw5-config is automatically detected
if it's present in the build machine (almost always because we need full
ncurses support with headers for Kconfig's menuconfig).
Since we don't have ncursesw support in buildroot just say no. Fixes:
http://autobuild.buildroot.net/results/89d/89d7ec7306411b15f9ffbc2051d0d316237b4c07/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nano/nano.mk

index aba4b4f152fefa41b60b853052a61ae35e6a9957..3707e7753d69b7aca7bf8da31f6432619fc95a70 100644 (file)
@@ -10,6 +10,7 @@ NANO_LICENSE = GPLv3+
 NANO_LICENSE_FILES = COPYING
 NANO_MAKE_ENV = CURSES_LIB="-lncurses"
 NANO_CONF_OPT = --without-slang
+NANO_CONF_ENV = ac_cv_prog_NCURSESW_CONFIG=false
 NANO_DEPENDENCIES = ncurses
 
 ifeq ($(BR2_PACKAGE_NANO_TINY),y)