mesa3d: Give possibility to external backends to enable DRI/Gallium
authorJérôme Pouiller <jezz@sysmic.org>
Thu, 30 Apr 2015 15:12:16 +0000 (17:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 May 2015 20:57:18 +0000 (22:57 +0200)
Thus, it is possible to force compilation of Gallium/DRI support in
mesa3d even if no Gallium/DRI drivers are selected. This is intended to
be used by external OpenGL provider (especialy further imx6 support).

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index dffbe460be13a7d4b3dc429cee1e2cfb61937cb7..f1c38bf6b2064d4185e96461bd05a4f4a969d523 100644 (file)
@@ -61,7 +61,7 @@ MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I915)   += i915
 MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_I965)   += i965
 MESA3D_DRI_DRIVERS-$(BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON) += radeon
 
-ifeq ($(MESA3D_GALLIUM_DRIVERS-y),)
+ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER),)
 MESA3D_CONF_OPTS += \
        --without-gallium-drivers
 else
@@ -70,7 +70,7 @@ MESA3D_CONF_OPTS += \
        --with-gallium-drivers=$(subst $(space),$(comma),$(MESA3D_GALLIUM_DRIVERS-y))
 endif
 
-ifeq ($(MESA3D_DRI_DRIVERS-y),)
+ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
 MESA3D_CONF_OPTS += \
        --without-dri-drivers --without-dri --disable-dri3
 else