package/bitcoin: unset the NDEBUG flag
authorDick Olsson <hi@senzilla.io>
Sun, 13 Jun 2021 18:45:09 +0000 (18:45 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 13 Jun 2021 19:58:05 +0000 (21:58 +0200)
Since https://git.buildroot.net/buildroot/commit/?id=5a8c50fe05afacc3cbe8e7347e238da9f242fab0
all packages are now built with NDEBUG, which broke Bitcoin builds.

Bitcoin is using assert(...) extensively with the assumption of it
never being a noop at runtime. So we cannot build with NDEBUG.
See: https://github.com/bitcoin/bitcoin/blob/0.21/src/compat/assumptions.h

Fixes:
    http://autobuild.buildroot.org/results/83b/83b6dc0b97b19888fb1187bbbca485961e58ce90/
    and so many more...

Signed-off-by: Dick Olsson <hi@senzilla.io>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/bitcoin/bitcoin.mk

index 142521835c1b9038dc680dbeea4bbcc221691efc..f485e4ee5ca13863f380111cbcc55f9a504d7c86 100644 (file)
@@ -13,6 +13,12 @@ BITCOIN_CPE_ID_VENDOR = bitcoin
 BITCOIN_CPE_ID_PRODUCT = bitcoin_core
 BITCOIN_DEPENDENCIES = host-pkgconf boost libevent
 BITCOIN_MAKE_ENV = BITCOIN_GENBUILD_NO_GIT=1
+# Bitcoin is using assert(...) extensively with the assumption of it
+# never being a noop at runtime. So we cannot build with NDEBUG.
+BITCOIN_CONF_ENV = \
+       CPPFLAGS="$(TARGET_CPPFLAGS) -UNDEBUG" \
+       CFLAGS="$(TARGET_CFLAGS) -UNDEBUG" \
+       CXXFLAGS="$(TARGET_CXXFLAGS) -UNDEBUG"
 BITCOIN_CONF_OPTS = \
        --disable-bench \
        --disable-wallet \