package/gdb: depend on libiberty
authorAdam Duskett <Aduskett@gmail.com>
Tue, 11 Feb 2020 16:34:01 +0000 (08:34 -0800)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 20 Feb 2020 21:07:17 +0000 (22:07 +0100)
If present, GDB may use a system installed libiberty. As such, we must ensure
that host-libiberty is installed first.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gdb/gdb.mk

index 46d745a8970cac4d7a04cb5389f528fb08b708cf..01f7e14460a0962723307b4327bbb3632c6cf409 100644 (file)
@@ -35,7 +35,9 @@ endif
 # For the host variant, we really want to build with XML support,
 # which is needed to read XML descriptions of target architectures. We
 # also need ncurses.
-HOST_GDB_DEPENDENCIES = host-expat host-ncurses
+# As for libiberty, gdb may use a system-installed one if present, so
+# we must ensure ours is installed first.
+HOST_GDB_DEPENDENCIES = host-expat host-libiberty host-ncurses
 
 # Disable building documentation
 GDB_MAKE_OPTS += MAKEINFO=true