package/asterisk: add optional spandsp support
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Oct 2018 13:13:58 +0000 (15:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 9 Oct 2018 13:13:29 +0000 (15:13 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/asterisk/asterisk.mk

index ea779cc8f64123484d5ac8250c21557ef0e338b2..4ed85743b0cd8e88bf9ae7fe2d10b576d07b749b 100644 (file)
@@ -84,7 +84,6 @@ ASTERISK_CONF_OPTS = \
        --without-resample \
        --without-sdl \
        --without-SDL_image \
-       --without-spandsp \
        --without-sqlite \
        --without-suppserv \
        --without-tds \
@@ -229,6 +228,13 @@ else
 ASTERISK_CONF_OPTS += --without-ssl
 endif
 
+ifeq ($(BR2_PACKAGE_SPANDSP),y)
+ASTERISK_DEPENDENCIES += spandsp
+ASTERISK_CONF_OPTS += --with-spandsp
+else
+ASTERISK_CONF_OPTS += --without-spandsp
+endif
+
 ifeq ($(BR2_PACKAGE_SPEEX)$(BR2_PACKAGE_SPEEXDSP),yy)
 ASTERISK_DEPENDENCIES += speex
 ASTERISK_CONF_OPTS += --with-speex --with-speexdsp