package/systemd: Add optional support for myhostname
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sat, 2 Jul 2016 13:59:07 +0000 (15:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 14:45:34 +0000 (16:45 +0200)
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index b44d57afe283060152e843b1a1456cf4d6a3ea25..b00ef2144fe0bd2d1ca4316df102716fa07c323b 100644 (file)
@@ -225,6 +225,17 @@ config BR2_PACKAGE_SYSTEMD_HOSTNAMED
 
          http://www.freedesktop.org/software/systemd/man/systemd-hostnamed.service.html
 
+config BR2_PACKAGE_SYSTEMD_MYHOSTNAME
+       bool "enable myhostname NSS plugin"
+       default y
+       help
+         nss-myhostname is a plug-in module for the GNU Name Service
+         Switch (NSS) functionality of the GNU C Library (glibc),
+         primarily providing hostname resolution for the locally
+         configured system hostname as returned by gethostname(2).
+
+         http://www.freedesktop.org/software/systemd/man/nss-myhostname.html
+
 config BR2_PACKAGE_SYSTEMD_TIMEDATED
        bool "enable timedate daemon"
        default y
index 423afcc1bb355a6eff0af43ddccdb443de18e510..cca3f0532b8ded684a088cdf57908f689fc7a2a3 100644 (file)
@@ -249,6 +249,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-hostnamed
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_MYHOSTNAME),y)
+SYSTEMD_CONF_OPTS += --enable-myhostname
+else
+SYSTEMD_CONF_OPTS += --disable-myhostname
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_TIMEDATED),y)
 SYSTEMD_CONF_OPTS += --enable-timedated
 else