package/duma: fix build with gcc 11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 31 Jul 2021 21:32:47 +0000 (23:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Jul 2021 22:02:50 +0000 (00:02 +0200)
Fix the following build failure with gcc 11:

In file included from dumapp.cpp:39:
dumapp.h:88:49: error: ISO C++17 does not allow dynamic exception specifications
   88 |     void * DUMA_CDECL operator new(DUMA_SIZE_T) throw(std::bad_alloc);
      |                                                 ^~~~~

While at it, also drop DUMA_CPP which does not seem to be set since the
addition of the package back in 2013 in commit
bda69bf4e4b642ab199ffa13c7356709885f129d

Fixes:
 - http://autobuild.buildroot.org/results/ed838a55f09841a643b05e5a7a7ca0a9d2882acd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/duma/duma.mk

index 0e8a623bde537793c5e1f46efe1f319f30fe1adb..906db872d5c92a45c23791d44feb34f3d4162a1d 100644 (file)
@@ -21,7 +21,7 @@ define DUMA_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) \
                OS=linux \
                DUMA_OPTIONS="$(DUMA_OPTIONS)" \
-               $(DUMA_CPP) -C $(@D)
+               CPPFLAGS="$(TARGET_CXXFLAGS) -std=c++11" -C $(@D)
 endef
 
 define DUMA_INSTALL_STAGING_CMDS