package/busybox: invert dependency with util-linux
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Jul 2018 09:45:30 +0000 (11:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 8 Jul 2018 10:22:14 +0000 (12:22 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Reviewed-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/busybox/busybox.mk
package/util-linux/util-linux.mk

index c42c4a470a882f0d29887c855dc82d6d9695b570..38f0246b4fd374bf176e8a092097a2f1d0d6a19e 100644 (file)
@@ -22,6 +22,7 @@ BUSYBOX_LDFLAGS = \
 
 # Packages that provide commands that may also be busybox applets:
 BUSYBOX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_UTIL_LINUX),util-linux) \
        $(if $(BR2_PACKAGE_VIM),vim) \
        $(if $(BR2_PACKAGE_WGET),wget) \
        $(if $(BR2_PACKAGE_WHOIS),whois)
index 80a8a08051f2303339ce8c1e207acdf47ed5ada9..76f4b97f5febc36a74451a66f1d267534f60fa3d 100644 (file)
@@ -31,12 +31,6 @@ HOST_UTIL_LINUX_DEPENDENCIES = host-pkgconf
 # We also don't want the host-python dependency
 HOST_UTIL_LINUX_CONF_OPTS = --without-python
 
-# If both util-linux and busybox are selected, make certain util-linux
-# wins the fight over who gets to have their utils actually installed
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-UTIL_LINUX_DEPENDENCIES += busybox
-endif
-
 # Prevent the installation from attempting to move shared libraries from
 # ${usrlib_execdir} (/usr/lib) to ${libdir} (/lib), since both paths are
 # the same when merged usr is in use.