- reenable linux26
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 31 Jan 2007 17:36:43 +0000 (17:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 31 Jan 2007 17:36:43 +0000 (17:36 -0000)
target/device/Config.in
target/device/Makefile.in
target/device/x86/Makefile.in
target/device/x86/i386/Makefile.in

index 788822f0c250a7e70dd00bcf53ede6be5bf68a5b..53ee055692a6b6b6413667383cfc037732cfbde9 100644 (file)
@@ -1,16 +1,8 @@
 menu "Board Support Options"
 
-config BR2_TARGET_GENERIC
-       bool "linux kernel"
-       default n
-       select BR2_PACKAGE_LINUX
-       help
-         Architecture or board dependant linux kernel.
-
 config BR2_PACKAGE_LINUX
-       bool "linux"
+       bool "linux kernel"
        default n
-       depends BR2_TARGET_GENERIC
        help
          The Linux kernel.
          http://www.kernel.org/
index c2d04a97a94b1f8ca3397521a709cd66fab4b6b0..fd9f03f115a8605ed1e28f10fc9cac5422362ddd 100644 (file)
@@ -1,3 +1,6 @@
 TARGET_DEVICE_DEPMOD:=target/device/x86/depmod.pl
 
 -include target/device/*/Makefile.in
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26
+endif
index 93041711bf2d9260fcb05e154c79874f71f93285..e3a995a7f7ce116b0ba314ab075defd0cb8d1635 100644 (file)
@@ -1,5 +1,3 @@
-ifeq ($(strip $(BR2_TARGET_GENERIC)),y)
 ifeq ($(strip $(BR2_i386)),y)
 include target/device/x86/i386/Makefile.in
 endif
-endif
index 0e6ab6148300f63ab26c1e70305ebc668b8e97a3..876304b7efe8d68b65655f80c0e430b7cea20c6c 100644 (file)
@@ -5,4 +5,3 @@ LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
 endif
 LINUX26_FORMAT=bzImage
 
-TARGETS+=linux26