package/amd-catalyst: Add command line tools
authorRomain Perier <romain.perier@free-electrons.com>
Tue, 23 Aug 2016 12:19:48 +0000 (14:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Aug 2016 16:09:45 +0000 (18:09 +0200)
The AMD Catalyst driver includes some command line tools for displaying
specific infos about the GL stack or to test 3D, like fglxinfo or
fgl_gears. This commit adds support to install such tools.

Signed-off-by: Romain Perier <romain.perier@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/amd-catalyst/Config.in
package/amd-catalyst/amd-catalyst.mk

index 1578324aac5fa5ff1d3191d5c6a22ef284183119..b10ed3b11fe14d8322d2660990f9a95444d82e87 100644 (file)
@@ -40,6 +40,11 @@ if BR2_PACKAGE_AMD_CATALYST_XORG
 config BR2_PACKAGE_PROVIDES_LIBGL
        default "amd-catalyst"
 
+config BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS
+       bool "command-line configuration tools"
+       help
+         Build and install the AMD command line tools.
+
 endif
 
 comment "amd-catalyst kernel module needs a kernel to be built"
index aca77816be3436dab037b95fa69201c5fc0582b9..4c1844c4d3504384d7c8e36002b1b6ba0cd13e21 100644 (file)
@@ -109,12 +109,32 @@ endef
 
 endif
 
+ifeq ($(BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS), y)
+AMD_CATALYST_CMDLINE_TOOLS_FILES = \
+       atiode \
+       atiodcli \
+       fgl_glxgears \
+       aticonfig \
+       amd-console-helper \
+       fglrxinfo
+
+define  AMD_CATALYST_INSTALL_CMDLINE_TOOLS
+       $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/sbin/atieventsd \
+               $(TARGET_DIR)/usr/sbin
+       $(foreach f,$(AMD_CATALYST_CMDLINE_TOOLS_FILES), \
+               $(INSTALL) -D -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/X11R6/bin/$(f) \
+                       $(TARGET_DIR)/usr/bin/$(f)
+       )
+endef
+endif
+
 define AMD_CATALYST_INSTALL_STAGING_CMDS
        $(call AMD_CATALYST_INSTALL_STAGING_XORG)
 endef
 
 define AMD_CATALYST_INSTALL_TARGET_CMDS
        $(call AMD_CATALYST_INSTALL_XORG)
+       $(call AMD_CATALYST_INSTALL_CMDLINE_TOOLS)
 endef
 
 $(eval $(generic-package))