- fix incorrect invocation of non-existing binary named "-find"
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 10:56:38 +0000 (10:56 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 10:56:38 +0000 (10:56 -0000)
  This bloated the target needlessly (and used to work before)

Makefile

index 5402016db9974f36a6563f8268f4ab519c6ce820..9b1b56bb8962c02731be9ffe0ca204333e520f71 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -250,14 +250,14 @@ endif
 
 $(PROJECT_BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
-       if ! [ -d "$(TARGET_DIR)/bin" ] ; then \
-               if [ -d "$(TARGET_SKELETON)" ] ; then \
-                       cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
+       if ! [ -d "$(TARGET_DIR)/bin" ]; then \
+               if [ -d "$(TARGET_SKELETON)" ]; then \
+                       cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/ ; \
                fi; \
                touch $(STAGING_DIR)/.fakeroot.00000 ; \
-               -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf ; \
-               -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf ; \
-       fi;
+       fi
+       -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
+       -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
        touch $@
 
 $(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root