toolchain/crosstool-NG: use IPv6 option
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Sat, 27 Nov 2010 20:50:49 +0000 (21:50 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 27 Nov 2010 21:29:03 +0000 (22:29 +0100)
Push the IPv6 option down to uClibc config

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-crosstool-ng/crosstool-ng.mk

index 97224a1d9a8b7fa0e4508e3ddea7ec72cb7a5192..92ed93272eaf81f40d92600991703c43b56839b7 100644 (file)
@@ -245,6 +245,13 @@ else
 CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_LFS)=.*:\# \1 is not set:;
 endif
 
+# Handle the IPv6 option
+ifneq ($(call qstrip,$(BR2_INET_IPV6)),)
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_IPV6) is not set:\1=y:;
+else
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_IPV6)=.*:\# \1 is not set:;
+endif
+
 # Instruct CT-NG's .config where to find the uClibc's .config
 CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;