package/libevent: do not drop python script with python 3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 22 Jan 2020 19:14:38 +0000 (20:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 2 Feb 2020 08:51:50 +0000 (09:51 +0100)
python script is compatible with python3 since 2.1.10 and
https://github.com/libevent/libevent/commit/532a8cc301db39e82166b4fe98146534fdc242ce

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libevent/libevent.mk

index a5ba7fdf6afe06c30ae6d5a84bed82a5a3500231..d6045593130e5186cd98fd5d7f16f85626d74373 100644 (file)
@@ -24,7 +24,7 @@ endef
 
 # libevent installs a python script to target - get rid of it if we
 # don't have python support enabled
-ifneq ($(BR2_PACKAGE_PYTHON),y)
+ifneq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
 endif