projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
89a0b73
)
package/openssh: add optional dependency on audit
author
Norbert Lange
<nolange79@gmail.com>
Fri, 5 Jun 2020 22:59:01 +0000
(
00:59
+0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Sat, 6 Jun 2020 20:26:38 +0000
(22:26 +0200)
Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openssh/openssh.mk
patch
|
blob
|
history
diff --git
a/package/openssh/openssh.mk
b/package/openssh/openssh.mk
index 515eec2c0359e3c7abc6ddf814f0f89bceb0d6bc..64ac22181b20adca651cbe44821511861e8f6280 100644
(file)
--- a/
package/openssh/openssh.mk
+++ b/
package/openssh/openssh.mk
@@
-39,6
+39,13
@@
else
OPENSSH_CONF_OPTS += --without-ssl-engine
endif
+ifeq ($(BR2_PACKAGE_AUDIT),y)
+OPENSSH_DEPENDENCIES += audit
+OPENSSH_CONF_OPTS += --with-audit=linux
+else
+OPENSSH_CONF_OPTS += --without-audit
+endif
+
ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
define OPENSSH_INSTALL_PAM_CONF
$(INSTALL) -D -m 644 $(@D)/contrib/sshd.pam.generic $(TARGET_DIR)/etc/pam.d/sshd