fbdump: Add new package fbdump.
authorDaniel Laird <danieljlaird@hotmail.com>
Wed, 27 Aug 2008 11:01:16 +0000 (11:01 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Wed, 27 Aug 2008 11:01:16 +0000 (11:01 -0000)
fbdump is a simple tool to capture snapshots from the Linux kernel framebuffer
device and write them out as a PPM file. Currently, most packed-pixel framebuffer
formats and the vga16 framebuffer are supported.

package/Config.in
package/fbdump/Config.in [new file with mode: 0644]
package/fbdump/fbdump.mk [new file with mode: 0644]

index 9e174bfce6240ded72ef8c32ac756c2ea7b32164..4cef7894563fb72a56bf38c6d08f576f70a8f961 100644 (file)
@@ -323,6 +323,7 @@ source "package/dialog/Config.in"
 
 comment "graphic libraries"
 source "package/directfb/Config.in"
+source "package/fbdump/Config.in"
 source "package/fusion/Config.in"
 source "package/imagemagick/Config.in"
 source "package/jpeg/Config.in"
diff --git a/package/fbdump/Config.in b/package/fbdump/Config.in
new file mode 100644 (file)
index 0000000..2f3a276
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_FBDUMP
+       bool "fbdump (Framebuffer Capture Tool)"
+       help
+          fbdump is a simple tool to capture snapshots from the Linux kernel framebuffer
+          device and write them out as a PPM file. Currently, most packed-pixel framebuffer
+       formats and the vga16 framebuffer are supported.
+
diff --git a/package/fbdump/fbdump.mk b/package/fbdump/fbdump.mk
new file mode 100644 (file)
index 0000000..5ebfd7e
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# fbdump
+#
+#############################################################
+FBDUMP_VERSION:=0.4.2
+FBDUMP_SOURCE:=fbdump-$(FBDUMP_VERSION).tar.gz
+FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
+FBDUMP_AUTORECONF = NO
+FBDUMP_CONF_ENV = ac_cv_func_malloc_0_nonnull=yes
+FBDUMP_INSTALL_STAGING = YES
+FBDUMP_INSTALL_TARGET = YES
+FBDUMP_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
+
+$(eval $(call AUTOTARGETS,package,fbdump))
+