swig: unbreak host-swig build when host has octave installed
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Nov 2013 08:34:02 +0000 (09:34 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Nov 2013 09:51:08 +0000 (10:51 +0100)
But not the octave development package:

checking for octave... octave
checking for mkoctfile... configure: error: mkoctfile is not installed

We don't need octace support, so fix it by explictly disabling it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/swig/swig.mk

index 94395ee10db2ce9cc50b638b1f4f2308d6729630..79839ea7ff6dd24da867d1d254c11b9e644cf2fe 100644 (file)
@@ -7,7 +7,10 @@
 SWIG_VERSION = 2.0.10
 SWIG_SITE = http://downloads.sourceforge.net/project/swig/swig/swig-$(SWIG_VERSION)
 SWIG_DEPENDENCIES = host-bison
-HOST_SWIG_CONF_OPT = --without-pcre --disable-ccache
+HOST_SWIG_CONF_OPT = \
+       --without-pcre \
+       --disable-ccache \
+       --without-octave
 SWIG_LICENSE = GPLv3+ BSD-2c BSD-3c
 SWIG_LICENSE_FILES = LICENSE LICENSE-GPL LICENSE-UNIVERSITIES