package/python3: add option to build on the host
authorNicolas Carrier <nicolas.carrier@orolia.com>
Fri, 20 Sep 2019 14:59:39 +0000 (14:59 +0000)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 27 Oct 2019 21:14:41 +0000 (22:14 +0100)
Some python scripts may be ran in the custom scripts a user can define
in the config. Allow the user to enable host-python3 explicitly.

If any of those require ssl, they will fail with no possible fix.
Add an option to enable openssl as well. This is made optional because
openssl significantly increases the build time.

Signed-off-by: Nicolas Carrier <nicolas.carrier@orolia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in.host
package/python3/Config.in.host [new file with mode: 0644]
package/python3/python3.mk

index 9eeb5c91a9cc56341f1e81f6c949210e64da10c7..3253f9f3619be67d27776fff04fefde281819bdc 100644 (file)
@@ -56,6 +56,7 @@ menu "Host utilities"
        source "package/python-lxml/Config.in.host"
        source "package/python-six/Config.in.host"
        source "package/python-xlrd/Config.in.host"
+       source "package/python3/Config.in.host"
        source "package/qemu/Config.in.host"
        source "package/raspberrypi-usbboot/Config.in.host"
        source "package/rauc/Config.in.host"
diff --git a/package/python3/Config.in.host b/package/python3/Config.in.host
new file mode 100644 (file)
index 0000000..70b5dac
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_HOST_PYTHON3
+       bool "host python3"
+       help
+         The python language interpreter. Host package.
+
+         http://www.python.org/
+
+if BR2_PACKAGE_HOST_PYTHON3
+
+config BR2_PACKAGE_HOST_PYTHON3_SSL
+       bool "ssl"
+       select BR2_PACKAGE_HOST_OPENSSL
+       help
+         _ssl module for host Python3.
+
+endif
index 060f9061ffe8c0b07f049f4aa5592b259ce55b1c..d6fda5c2742ed62c276039d94232092868196258 100644 (file)
@@ -26,8 +26,7 @@ HOST_PYTHON3_CONF_OPTS += \
        --enable-unicodedata \
        --disable-test-modules \
        --disable-idle3 \
-       --disable-ossaudiodev \
-       --disable-openssl
+       --disable-ossaudiodev
 
 # Make sure that LD_LIBRARY_PATH overrides -rpath.
 # This is needed because libpython may be installed at the same time that
@@ -42,6 +41,12 @@ PYTHON3_DEPENDENCIES = host-python3 libffi
 
 HOST_PYTHON3_DEPENDENCIES = host-expat host-zlib host-libffi
 
+ifeq ($(BR2_PACKAGE_HOST_PYTHON3_SSL),y)
+HOST_PYTHON3_DEPENDENCIES += host-openssl
+else
+HOST_PYTHON3_CONF_OPTS += --disable-openssl
+endif
+
 PYTHON3_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_PYTHON3_READLINE),y)