package/linux: drop useless intermediate DTS booleans
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 26 Feb 2018 17:47:21 +0000 (18:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 8 Mar 2018 08:08:15 +0000 (09:08 +0100)
Just use whatever the user specified in the list. An empty list means no
DTS was specified.

No need to add legacy option, as the behaviour does not change.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Simon van der Veldt <simon.vanderveldt@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Tested-by: Joshua Henderson <joshua.henderson@microchip.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/Config.in
linux/linux.mk

index dadfc88da4d0f63cc9c76be1c0f17d81c71f0efc..3447290a699d4a866badfff815ce7c475acf63bc 100644 (file)
@@ -363,35 +363,19 @@ config BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT
 config BR2_LINUX_KERNEL_APPENDED_DTB
        bool
 
-config BR2_LINUX_KERNEL_USE_INTREE_DTS
-       bool "Use a device tree present in the kernel"
-       help
-         Use a device tree source distributed with
-         the kernel sources. The dts files are located
-         in the arch/<arch>/boot/dts folder.
-
 config BR2_LINUX_KERNEL_INTREE_DTS_NAME
-       string "Device Tree Source file names"
-       depends on BR2_LINUX_KERNEL_USE_INTREE_DTS
+       string "In-tree Device Tree Source file names"
        help
-         Name of the device tree source file, without
+         Name of in-tree device tree source file, without
          the trailing .dts. You can provide a list of
          dts files to build, separated by spaces.
 
-config BR2_LINUX_KERNEL_USE_CUSTOM_DTS
-       bool "Use a custom device tree file"
-       help
-         Use a custom device tree file, i.e, a device
-         tree file that does not belong to the kernel
-         source tree.
-
 config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
-       string "Device Tree Source file paths"
-       depends on BR2_LINUX_KERNEL_USE_CUSTOM_DTS
+       string "Out-of-tree Device Tree Source file paths"
        help
-         Path to the device tree source files. You can
-         provide a list of dts paths to copy and build,
-         separated by spaces.
+         Path to to out-of-tree device tree source files.
+         You can provide a list of dts paths to copy and
+         build, separated by spaces.
 
 endif
 
index 28d799f946f0dc277c3424b9618a46e823615641..e98b25cb724a7a6041c22c9b23f178e9dd6e6f5b 100644 (file)
@@ -125,17 +125,13 @@ endif
 # going to be installed in the target filesystem.
 LINUX_VERSION_PROBED = `$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelrelease 2>/dev/null`
 
-ifeq ($(BR2_LINUX_KERNEL_USE_INTREE_DTS),y)
 KERNEL_DTS_NAME += $(call qstrip,$(BR2_LINUX_KERNEL_INTREE_DTS_NAME))
-endif
 
-ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),y)
 # We keep only the .dts files, so that the user can specify both .dts
 # and .dtsi files in BR2_LINUX_KERNEL_CUSTOM_DTS_PATH. Both will be
 # copied to arch/<arch>/boot/dts, but only the .dts files will
 # actually be generated as .dtb.
 KERNEL_DTS_NAME += $(basename $(filter %.dts,$(notdir $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))))
-endif
 
 KERNEL_DTBS = $(addsuffix .dtb,$(KERNEL_DTS_NAME))