inadyn: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:19:00 +0000 (15:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:41:16 +0000 (00:41 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/inadyn/inadyn.mk

index 73d95dbada9df6dc62e51d2a3a66eaa4882240fb..b002f94e8ddd45faeb778f8accdf37ec7748e32a 100644 (file)
@@ -20,10 +20,8 @@ INADYN_CONF_OPTS += --disable-ssl
 endif
 
 define INADYN_INSTALL_SAMPLE_CONFIG
-       @if [ ! -f $(TARGET_DIR)/etc/inadyn.conf ]; then \
-               $(INSTALL) -D -m 0600 package/inadyn/inadyn.conf \
-                       $(TARGET_DIR)/etc/inadyn.conf; \
-       fi
+       $(INSTALL) -D -m 0600 package/inadyn/inadyn.conf \
+               $(TARGET_DIR)/etc/inadyn.conf
 endef
 INADYN_POST_INSTALL_TARGET_HOOKS += INADYN_INSTALL_SAMPLE_CONFIG