perl-file-util: new package
authorCarlos Santos <casantos@datacom.ind.br>
Mon, 2 Mar 2015 10:55:47 +0000 (07:55 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Mar 2015 22:39:56 +0000 (23:39 +0100)
The host variant is useful to build some third-party packages that
need this Perl module.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-file-util/Config.in [new file with mode: 0644]
package/perl-file-util/perl-file-util.hash [new file with mode: 0644]
package/perl-file-util/perl-file-util.mk [new file with mode: 0644]

index ba45f3220898353b1b6a113bd94b836514824296..584887b7849add8eb18daec1f19b5942b620ed7c 100644 (file)
@@ -473,6 +473,7 @@ endif
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
        source "package/perl-datetime-tiny/Config.in"
+       source "package/perl-file-util/Config.in"
        source "package/perl-gd/Config.in"
        source "package/perl-gdgraph/Config.in"
        source "package/perl-gdtextutil/Config.in"
diff --git a/package/perl-file-util/Config.in b/package/perl-file-util/Config.in
new file mode 100644 (file)
index 0000000..871be98
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_FILE_UTIL
+       bool "perl-file-util"
+       help
+         Easy, versatile, portable file handling
+
+         https://github.com/tommybutler/file-util/wiki
diff --git a/package/perl-file-util/perl-file-util.hash b/package/perl-file-util/perl-file-util.hash
new file mode 100644 (file)
index 0000000..1e613dc
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    93c572b4c54743a7ef383486dd2c4014 File-Util-4.132140.tar.gz
+sha256 4233c493468da8b34f2df19b191aaa400f328d877c8c023605e43385976a99d1 File-Util-4.132140.tar.gz
diff --git a/package/perl-file-util/perl-file-util.mk b/package/perl-file-util/perl-file-util.mk
new file mode 100644 (file)
index 0000000..c8b4441
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# perl-file-util
+#
+################################################################################
+
+PERL_FILE_UTIL_VERSION = 4.132140
+PERL_FILE_UTIL_SOURCE = File-Util-$(PERL_FILE_UTIL_VERSION).tar.gz
+PERL_FILE_UTIL_SITE = $(BR2_CPAN_MIRROR)/authors/id/T/TO/TOMMY
+PERL_FILE_UTIL_DEPENDENCIES = perl host-perl-module-build
+PERL_FILE_UTIL_LICENSE = Artistic or GPLv1+
+PERL_FILE_UTIL_LICENSE_FILES = COPYING LICENSE
+
+$(eval $(perl-package))
+$(eval $(host-perl-package))