package/json-for-modern-cpp: enable multiple headers by default
authorDimitrij Kotrev <dimitrij.kotrev@googlemail.com>
Mon, 15 Mar 2021 08:17:02 +0000 (09:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Mar 2021 20:57:52 +0000 (21:57 +0100)
json-for-modern-cpp provides an option to enable multiple headers support.
Currently this option is disabled and the package creates just a
single header: "nlohmann/json.hpp", which contains everything. Enabling
this option, splits this single header into multiple ones. First of all
this provides an additional header: "nlohmann/json_fwd.hpp", which contains
only forwarding declarations of types provided by this library. This
gives you a more finer control over include dependencies and can speed up
build times significantly. The top level header: "nlohmann/json.hpp" is
still there and therefore code which used it before, would stay compatible.

Signed-off-by: Dimitrij Kotrev <dimitrij.kotrev@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/json-for-modern-cpp/json-for-modern-cpp.mk

index 6e21723fd496cce632d3a645fe97c4a37c8e474a..94cdc909f3ba39c2efd6aab4570261ce6d3f184e 100644 (file)
@@ -12,6 +12,6 @@ JSON_FOR_MODERN_CPP_LICENSE_FILES = LICENSE.MIT
 JSON_FOR_MODERN_CPP_INSTALL_STAGING = YES
 # header only library
 JSON_FOR_MODERN_CPP_INSTALL_TARGET = NO
-JSON_FOR_MODERN_CPP_CONF_OPTS = -DJSON_BuildTests=OFF
+JSON_FOR_MODERN_CPP_CONF_OPTS = -DJSON_BuildTests=OFF -DJSON_MultipleHeaders=ON
 
 $(eval $(cmake-package))