binutils: add avr32 special version
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 10:19:34 +0000 (11:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 22:54:42 +0000 (23:54 +0100)
 * Add a new binutils version 2.18-avr32-1.0.1 to the Config.in

 * Use a different site to download avr32 binutils version in binutils.mk

 * Only apply patches from the patch directory if it exists in
   binutils.mk

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/binutils/Config.in
toolchain/binutils/binutils.mk

index b892b6f74f30ade847787c467b80abfd1ef5d282..4405bcb492fa25a111a3afb45de98a34ab1f0b16 100644 (file)
@@ -24,6 +24,10 @@ choice
                depends on BR2_DEPRECATED
                bool "binutils 2.18.50.0.9"
 
+       config BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
+              depends on BR2_avr32
+              bool "binutils 2.18-avr32-1.0.1"
+
        config BR2_BINUTILS_VERSION_2_19
                depends on !BR2_avr32 && !BR2_nios2
                depends on BR2_DEPRECATED
@@ -46,6 +50,7 @@ config BR2_BINUTILS_VERSION
        default "2.17"          if BR2_BINUTILS_VERSION_2_17
        default "2.18"          if BR2_BINUTILS_VERSION_2_18
        default "2.18.50.0.9"   if BR2_BINUTILS_VERSION_2_18_50_0_9
+       default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
        default "2.19"          if BR2_BINUTILS_VERSION_2_19
        default "2.19.1"        if BR2_BINUTILS_VERSION_2_19_1
        default "2.20"          if BR2_BINUTILS_VERSION_2_20
index 8cddf2d50173bf316cb67371acc6165994982828..38bee9ecc875e6e3d8e2e55448efb14659a6de39 100644 (file)
@@ -22,6 +22,9 @@ endif
 ifeq ($(BINUTILS_VERSION),2.17)
 BINUTILS_SITE:=$(BR2_GNU_MIRROR)/binutils/
 endif
+ifeq ($(findstring avr32,$(BINUTILS_VERSION)),avr32)
+BINUTILS_SITE:=ftp://www.at91.com/pub/buildroot/
+endif
 
 # We do not rely on the host's gmp/mpfr but use a known working one
 BINUTILS_HOST_PREREQ:=
@@ -79,7 +82,9 @@ $(BINUTILS_DIR)/.unpacked: $(DL_DIR)/$(BINUTILS_SOURCE)
 binutils-patched: $(BINUTILS_DIR)/.patched
 $(BINUTILS_DIR)/.patched: $(BINUTILS_DIR)/.unpacked
        # Apply appropriate binutils patches.
+ifneq ($(wildcard $(BINUTILS_PATCH_DIR)),)
        toolchain/patch-kernel.sh $(BINUTILS_DIR) $(BINUTILS_PATCH_DIR) \*.patch $(BINUTILS_PATCH_EXTRA)
+endif
        touch $@
 
 $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched