linux-tools: add cpupower
authorRomain Naour <romain.naour@openwide.fr>
Tue, 14 Jul 2015 17:35:13 +0000 (19:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 21:22:58 +0000 (23:22 +0200)
This patch is based on the patch send by James Knight:
http://lists.busybox.net/pipermail/buildroot/2015-May/128754.html

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Cc: James Knight <james.knight@rockwellcollins.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/Config.in
linux/Config.tools.in [new file with mode: 0644]
linux/linux-tool-cpupower.mk [new file with mode: 0644]

index 8c86a1ae7eebf2309aa0617e569e7404cc518f00..097cde5469c2229d2573a1d1e566bd778a7822c3 100644 (file)
@@ -364,6 +364,9 @@ config BR2_LINUX_KERNEL_INSTALL_TARGET
 # Linux extensions
 source "linux/Config.ext.in"
 
+# Linux tools
+source "linux/Config.tools.in"
+
 endif # BR2_LINUX_KERNEL
 
 endmenu
diff --git a/linux/Config.tools.in b/linux/Config.tools.in
new file mode 100644 (file)
index 0000000..008e68c
--- /dev/null
@@ -0,0 +1,11 @@
+menu "Linux Kernel Tools"
+
+config BR2_LINUX_KERNEL_TOOL_CPUPOWER
+       bool "cpupower"
+       depends on !BR2_bfin # pciutils
+       select BR2_PACKAGE_PCIUTILS
+       help
+         cpupower is a collection of tools to examine and tune power
+         saving related features of your processor.
+
+endmenu
diff --git a/linux/linux-tool-cpupower.mk b/linux/linux-tool-cpupower.mk
new file mode 100644 (file)
index 0000000..4551cda
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# cpupower
+#
+################################################################################
+
+LINUX_TOOLS += cpupower
+
+CPUPOWER_DEPENDENCIES = pciutils
+
+CPUPOWER_MAKE_OPTS = CROSS=$(TARGET_CROSS) \
+       CPUFREQ_BENCH=false \
+       DEBUG=false
+
+define CPUPOWER_BUILD_CMDS
+       $(Q)if test ! -f $(@D)/tools/power/cpupower/Makefile ; then \
+               echo "Your kernel version is too old and does not have the cpupower tool." ; \
+               echo "At least kernel 3.4 must be used." ; \
+               exit 1 ; \
+       fi
+
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+               $(CPUPOWER_MAKE_OPTS) \
+               cpupower
+endef
+
+define CPUPOWER_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+               $(CPUPOWER_MAKE_OPTS) \
+               DESTDIR=$(STAGING_DIR) \
+               cpupower_install
+endef
+
+define CPUPOWER_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+               $(CPUPOWER_MAKE_OPTS) \
+               DESTDIR=$(TARGET_DIR) \
+               cpupower_install
+endef