package/apr-util: add optional dependency to mysql
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 5 Oct 2014 17:38:55 +0000 (19:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 21:23:01 +0000 (22:23 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apr-util/apr-util.mk

index e22efb23e250813848df862260803a747f5b108d..42506bb21f0aad71e3611776d958cbb22b00dfcb 100644 (file)
@@ -32,6 +32,13 @@ else
 APR_UTIL_CONF_OPTS += --without-gdbm
 endif
 
+ifeq ($(BR2_PACKAGE_MYSQL),y)
+APR_UTIL_CONF_OPTS += --with-mysql="$(STAGING_DIR)/usr"
+APR_UTIL_DEPENDENCIES += mysql
+else
+APR_UTIL_CONF_OPTS += --without-mysql
+endif
+
 ifeq ($(BR2_PACKAGE_SQLITE),y)
 APR_UTIL_CONF_OPTS += --with-sqlite3="$(STAGING_DIR)/usr"
 APR_UTIL_DEPENDENCIES += sqlite