mesa3d: enable DRI drivers for xorg-less configurations
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 28 Mar 2016 21:48:15 +0000 (18:48 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Mar 2016 18:23:57 +0000 (20:23 +0200)
mesa3d can in fact build the DRI infrastructure/drivers just fine
without lingering x11 libs around, it just needs libdrm & friends which
are already accounted for.

So make the libGL (full OpenGL) providing abilities dependant on x11
being present.

It serves it's purpose for EGL+GLES hardware acceleration, and can in
fact be built without them, but it's probably not very useful (still,
leave the option for people inclined to do so).

Simple test defconfig:

BR2_arm=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_PACKAGE_MESA3D=y
BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST=y
BR2_PACKAGE_MESA3D_DRI_DRIVER_NOUVEAU=y
BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON=y
BR2_PACKAGE_MESA3D_OPENGL_EGL=y
BR2_PACKAGE_MESA3D_OPENGL_ES=y

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index a7aa297624f424e8abd08a971183c737d9215050..8f6ab75c6b96e3215ea6ba75ca54a9e52494a752 100644 (file)
@@ -28,13 +28,14 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
 
 config BR2_PACKAGE_MESA3D_DRI_DRIVER
        select BR2_PACKAGE_MESA3D_DRIVER
-       select BR2_PACKAGE_HAS_LIBGL
+       select BR2_PACKAGE_HAS_LIBGL if BR2_PACKAGE_XORG7
        select BR2_PACKAGE_XLIB_LIBXSHMFENCE if BR2_PACKAGE_XPROTO_DRI3PROTO
        select BR2_PACKAGE_XPROTO_PRESENTPROTO if BR2_PACKAGE_XPROTO_DRI3PROTO
        bool
 
 config BR2_PACKAGE_PROVIDES_LIBGL
-       default "mesa3d" if BR2_PACKAGE_MESA3D_DRI_DRIVER
+       default "mesa3d" if BR2_PACKAGE_MESA3D_DRI_DRIVER && \
+               BR2_PACKAGE_XORG7
 
 config BR2_PACKAGE_MESA3D_DRIVER
        bool
@@ -89,8 +90,6 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VIRGL
 comment "DRI drivers need X.Org"
        depends on !BR2_PACKAGE_XORG7
 
-if BR2_PACKAGE_XORG7
-
 comment "DRI drivers"
 
 config BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST
@@ -130,8 +129,6 @@ config BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON
        help
          Legacy Radeon driver for R100 series GPUs.
 
-endif # BR2_PACKAGE_XORG7
-
 comment "Off-screen Rendering"
 
 config BR2_PACKAGE_MESA3D_OSMESA
index ff2f932823898ad11e3df631d172a0e0145a31ae..b8ccd1f9d6f42d86b510e703d7c9de666f694e12 100644 (file)
@@ -102,7 +102,10 @@ endif
 ifeq ($(BR2_PACKAGE_XLIB_LIBXXF86VM),y)
 MESA3D_DEPENDENCIES += xlib_libXxf86vm
 endif
+# libGL is only provided for a full xorg stack
+ifeq ($(BR2_PACKAGE_XORG7),y)
 MESA3D_PROVIDES += libgl
+endif
 MESA3D_CONF_OPTS += \
        --enable-shared-glapi \
        --enable-driglx-direct \