at91bootstrap: fix install procedure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 31 May 2010 17:31:44 +0000 (19:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jun 2010 11:38:47 +0000 (13:38 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/at91bootstrap/at91bootstrap.mk

index bad5ceec9bc585f4ad22bf588ff214d6c5757f77..fc7206eaf387bfdd56a308a16ac29a56298bb1e1 100644 (file)
@@ -56,11 +56,10 @@ $(AT91BOOTSTRAP_TARGET): $(AT91BOOTSTRAP_DIR)/.configured
 
 $(AT91BOOTSTRAP_DIR)/.installed:: $(AT91BOOTSTRAP_TARGET)
        mkdir -p $(BINARIES_DIR)
-       make MEMORY=$(AT91BOOTSTRAP_MEMORY) \
-               CROSS_COMPILE=$(TARGET_CROSS) \
-               -C $(AT91BOOTSTRAP_DIR) boot
-       make DESTDIR=$(BINARIES_DIR) -C $(AT91BOOTSTRAP_DIR) install || \
-               echo "Could not copy bootstrap to BINARIES_DIR"
+       make MEMORY=$(AT91BOOTSTRAP_MEMORY)     \
+               CROSS_COMPILE=$(TARGET_CROSS)   \
+               DESTDIR=$(BINARIES_DIR)         \
+               -C $(AT91BOOTSTRAP_DIR) install
        touch $@
 
 .PHONY: at91bootstrap at91bootstrap-source