divine: new package
authorSven Neumann <s.neumann@raumfeld.com>
Fri, 11 Sep 2009 10:47:50 +0000 (12:47 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 11 Sep 2009 11:47:22 +0000 (13:47 +0200)
DiVine is the DirectFB virtual input extension.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/divine/Config.in [new file with mode: 0644]
package/divine/divine.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 21970224cc75d6ef5dc631e23454b8f7d4ac5865..1250b9430584a9ae1354140920b4d6404d3eec1b 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1,6 +1,6 @@
 2009.11, Not yet released:
 
-       New packages: libarchive
+       New packages: divine, libarchive
 
        Issues resolved (http://bugs.uclibc.org):
 
index cf4db520fb7d71d8532e043b698cbd4058436f96..fc97222634603e6d286952247e2dbd8bbe18ec2e 100644 (file)
@@ -297,6 +297,7 @@ source "package/dialog/Config.in"
 comment "graphic libraries"
 source "package/directfb/Config.in"
 source "package/directfb-examples/Config.in"
+source "package/divine/Config.in"
 source "package/fbdump/Config.in"
 source "package/imagemagick/Config.in"
 source "package/jpeg/Config.in"
diff --git a/package/divine/Config.in b/package/divine/Config.in
new file mode 100644 (file)
index 0000000..8202292
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_DIVINE
+       bool "directfb virtual input extension"
+       depends on BR2_PACKAGE_DIRECTFB
+       help
+         DiVine provides a DirectFB input driver that reads input
+         events from a pipe and dispatches them via a virtual input
+         device. It also installs the tool 'spooky' that allows to
+         send input events to DirectFB applications.
diff --git a/package/divine/divine.mk b/package/divine/divine.mk
new file mode 100644 (file)
index 0000000..554ee63
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# divine
+#
+#############################################################
+
+DIVINE_VERSION := 0.4.0
+DIVINE_SITE := http://www.directfb.org/downloads/Extras
+DIVINE_SOURCE = DiVine-$(DIVINE_VERSION).tar.gz
+DIVINE_INSTALL_STAGING = YES
+DIVINE_INSTALL_TARGET = YES
+DIVINE_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,divine))