package/rtty: new package
authorJianhui Zhao <zhaojh329@gmail.com>
Tue, 10 Mar 2020 15:06:06 +0000 (23:06 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 22 Mar 2020 20:43:45 +0000 (21:43 +0100)
Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
[Thomas:
 - add entry in DEVELOPERS file
 - add -DRTTY_SSL_SUPPORT=OFF to explicitly disable SSL support
 - fix license file name in the hash file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/rtty/Config.in [new file with mode: 0644]
package/rtty/rtty.hash [new file with mode: 0644]
package/rtty/rtty.mk [new file with mode: 0644]

index aab7d4b18a65c3028b613b29cc0b11919125560f..8ea08739f74bfd8ca730dfcb8b88c3d74a9f82b5 100644 (file)
@@ -1266,6 +1266,9 @@ F:        package/wmctrl/
 F:     package/x11r7/xdriver_xf86-video-imx/
 F:     package/x11r7/xdriver_xf86-video-imx-viv/
 
+N:     Jianhui Zhao <zhaojh329@gmail.com>
+F:     package/rtty/
+
 N:     Joao Pinto <jpinto@synopsys.com>
 F:     board/synopsys/vdk/
 F:     configs/snps_aarch64_vdk_defconfig
index cba756d9f116748e7390626f021fcf11a4aa3190..2b903140dfc846c1e9309b95113359220f41cacf 100644 (file)
@@ -2280,6 +2280,7 @@ comment "Utilities"
        source "package/pdmenu/Config.in"
        source "package/pinentry/Config.in"
        source "package/ranger/Config.in"
+       source "package/rtty/Config.in"
        source "package/screen/Config.in"
        source "package/sudo/Config.in"
        source "package/terminology/Config.in"
diff --git a/package/rtty/Config.in b/package/rtty/Config.in
new file mode 100644 (file)
index 0000000..badb329
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RTTY
+       bool "rtty"
+       select BR2_PACKAGE_LIBEV
+       help
+         Access your device's terminal from anywhere via the web.
+
+         https://github.com/zhaojh329/rtty
diff --git a/package/rtty/rtty.hash b/package/rtty/rtty.hash
new file mode 100644 (file)
index 0000000..51d4b9f
--- /dev/null
@@ -0,0 +1,2 @@
+sha256  6faafe75d82edbcfe154da5f1ffc0ddfd14dd88a2315f19aeed7f2631df96f41  rtty-7.1.2.tar.gz
+sha256  99efed4bbc0b62f96f999ef23399e38234fb91651af734fd389a52b033a85b55  LICENSE
diff --git a/package/rtty/rtty.mk b/package/rtty/rtty.mk
new file mode 100644 (file)
index 0000000..21ba385
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# rtty
+#
+################################################################################
+
+RTTY_VERSION = 7.1.2
+RTTY_SITE = https://github.com/zhaojh329/rtty/releases/download/v$(RTTY_VERSION)
+RTTY_LICENSE = MIT
+RTTY_LICENSE_FILES = LICENSE
+RTTY_DEPENDENCIES = libev
+RTTY_CONF_OPTS = -DRTTY_SSL_SUPPORT=OFF
+
+$(eval $(cmake-package))