gnutls: make it non-wchar friendly
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 26 Dec 2012 03:55:48 +0000 (03:55 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Dec 2012 22:39:59 +0000 (23:39 +0100)
Make gnutls work for non-wchar toolchains.
It's just a matter of throwing a helping hand to configure.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/connman/Config.in
package/gnutls/Config.in
package/gnutls/gnutls.mk
package/libsoup/Config.in
package/network-manager/Config.in

index 93f9ab518f466e6053e8d50f70a6573fa96d90d4..4c9741b5303ec83e8131099b9a301e2875434faf 100644 (file)
@@ -5,7 +5,7 @@ config BR2_PACKAGE_CONNMAN
        select BR2_PACKAGE_IPTABLES
        select BR2_PACKAGE_GNUTLS
        depends on !(BR2_UCLIBC_VERSION_0_9_31 || BR2_UCLIBC_VERSION_0_9_32)
-       depends on BR2_USE_WCHAR # libglib2 and gnutls
+       depends on BR2_USE_WCHAR # libglib2
        depends on BR2_INET_IPV6
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
        depends on BR2_USE_MMU # dbus
index 556caea2d26a56fc7df63c9ece4abb781d5f7da6..cedf120ee768ee5af0c79363b5528578e8278646 100644 (file)
@@ -1,12 +1,8 @@
 config BR2_PACKAGE_GNUTLS
        bool "gnutls"
        select BR2_PACKAGE_LIBGCRYPT
-       depends on BR2_USE_WCHAR
        help
          GnuTLS is a secure communications library implementing the SSL
          and TLS protocols and technologies around them.
 
          http://www.gnu.org/software/gnutls/gnutls.html
-
-comment "gnutls requires a toolchain with WCHAR support"
-       depends on !BR2_USE_WCHAR
index 2634642572d142c22c369e144da5509564416a50..506d7f5b823fad52ae3427c4c2ef292272a63a5e 100644 (file)
@@ -10,7 +10,10 @@ GNUTLS_SITE = $(BR2_GNU_MIRROR)/gnutls
 GNUTLS_LICENSE = GPLv3+ LGPLv2.1+
 GNUTLS_LICENSE_FILES = COPYING lib/COPYING
 GNUTLS_DEPENDENCIES = host-pkgconf libgcrypt $(if $(BR2_PACKAGE_ZLIB),zlib)
-GNUTLS_CONF_ENV = acl_cv_rpath=no
+GNUTLS_CONF_ENV = acl_cv_rpath=no \
+       ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
+       gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \
+       gt_cv_c_wint_t=$(if $(BR2_USE_WCHAR),yes,no)
 GNUTLS_CONF_OPT = --with-libgcrypt --without-libgcrypt-prefix \
                --without-p11-kit --disable-rpath
 GNUTLS_INSTALL_STAGING = YES
index 57b425f283aaefb9975391cdb7d1338062118615..c3b4ceb1811920dcef73283edb6860965b627c94 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBSOUP
        bool "libsoup"
-       depends on BR2_USE_WCHAR # glib2 and gnutls
+       depends on BR2_USE_WCHAR # glib2
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
index e2324d6602e9301bfc979c83316f3740489986aa..f2544da17ad09cf2b0e7c32f0c230a734ee78eab 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_NETWORK_MANAGER
        select BR2_PACKAGE_DBUS
        depends on BR2_INET_IPV6
        depends on BR2_LARGEFILE # acl
-       depends on BR2_USE_WCHAR # libglib2 and gnutls
+       depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
        depends on BR2_USE_MMU # dbus
        select BR2_PACKAGE_DBUS_GLIB