package/redis: security bump to version 6.0.9
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 14 Nov 2020 14:48:47 +0000 (15:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Nov 2020 16:14:27 +0000 (17:14 +0100)
This release fixes a potential heap overflow when using a heap allocator
other than jemalloc or glibc's malloc. See:
https://github.com/redis/redis/pull/7963

https://raw.githubusercontent.com/redis/redis/6.0/00-RELEASENOTES

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/redis/0001-uclibc.patch
package/redis/redis.hash
package/redis/redis.mk

index 3329a60edc9933bd623c9654af499e04c349b462..197f43e7a72c755afd69a9764c6f5301206d0c0f 100644 (file)
@@ -10,6 +10,8 @@ Signed-off-by: Daniel Price <daniel.price@gmail.com>
 Signed-off-by: Martin Bark <martin@barkynet.com>
 [Titouan: adapt to 5.0.4]
 Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
+[Fabrice: update for 6.0.9]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 
 =========================================================================
 diff -ur old/src/config.h new/src/config.h
@@ -21,6 +23,6 @@ diff -ur old/src/config.h new/src/config.h
  /* Test for backtrace() */
 -#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
 +#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__) && !defined(__UCLIBC__)) || \
-     defined(__FreeBSD__) || (defined(__OpenBSD__) && defined(USE_BACKTRACE))\
+     defined(__FreeBSD__) || ((defined(__OpenBSD__) || defined(__NetBSD__)) && defined(USE_BACKTRACE))\
   || defined(__DragonFly__)
  #define HAVE_BACKTRACE 1
index d686d59847b2f86895965f4c575604bd02807879..a16bf9dffbd881927cd9c4dd88463227d172082d 100644 (file)
@@ -1,5 +1,5 @@
 # From https://github.com/redis/redis-hashes/blob/master/README
-sha256  04fa1fddc39bd1aecb6739dd5dd73858a3515b427acd1e2947a66dadce868d68  redis-6.0.8.tar.gz
+sha256  dc2bdcf81c620e9f09cfd12e85d3bc631c897b2db7a55218fd8a65eaa37f86dd  redis-6.0.9.tar.gz
 
 # Locally calculated
 sha256  97f0a15b7bbae580d2609dad2e11f1956ae167be296ab60f4691ab9c30ee9828  COPYING
index c567d3200d141de13046b129b2229567ee08fd66..b0d8e1cd513b2b057c88c406f929d49325fde5f6 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-REDIS_VERSION = 6.0.8
+REDIS_VERSION = 6.0.9
 REDIS_SITE = http://download.redis.io/releases
 REDIS_LICENSE = BSD-3-Clause (core); MIT and BSD family licenses (Bundled components)
 REDIS_LICENSE_FILES = COPYING