git: fix static link with openssl
authorBaruch Siach <baruch@tkos.co.il>
Tue, 10 Feb 2015 08:39:59 +0000 (10:39 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Feb 2015 11:26:41 +0000 (12:26 +0100)
openssl needs -lz when building statically.

Fixes:
http://autobuild.buildroot.net/results/4b3/4b33f3f415776cf43be0910b583d222711a03cad/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/git/git.mk

index b5244aca04740845dfbe42a8cfdf44541b9a0d5e..674095df6043620615f2a41c1cc5f863d4a13283 100644 (file)
@@ -14,6 +14,7 @@ GIT_DEPENDENCIES = zlib host-gettext
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
        GIT_DEPENDENCIES += openssl
        GIT_CONF_OPTS += --with-openssl
+       GIT_CONF_ENV_LIBS += $(if $(BR2_STATIC_LIBS),-lz)
 else
        GIT_CONF_OPTS += --without-openssl
 endif
@@ -41,7 +42,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
        GIT_DEPENDENCIES += libiconv
-       GIT_CONF_ENV += LIBS=-liconv
+       GIT_CONF_ENV_LIBS += -liconv
        GIT_CONF_OPTS += --with-iconv=/usr/lib
 else
        GIT_CONF_OPTS += --without-iconv
@@ -56,7 +57,7 @@ endif
 
 # assume yes for these tests, configure will bail out otherwise
 # saying error: cannot run test program while cross compiling
-GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
-       ac_cv_snprintf_returns_bogus=yes
+GIT_CONF_ENV = ac_cv_fread_reads_directories=yes \
+       ac_cv_snprintf_returns_bogus=yes LIBS='$(GIT_CONF_ENV_LIBS)'
 
 $(eval $(autotools-package))