openvpn: bump to version 2.2.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 27 Apr 2011 18:05:10 +0000 (15:05 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Apr 2011 18:55:34 +0000 (20:55 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch [deleted file]
package/openvpn/openvpn-fix-build-with-disable-crypto.patch [new file with mode: 0644]
package/openvpn/openvpn-fix-tmpdir.patch [new file with mode: 0644]
package/openvpn/openvpn.mk

diff --git a/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch b/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch
deleted file mode 100644 (file)
index 5466558..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-[PATCH] fix build with --disable-crypto
-
-options.c is missing the definition for struct context when built with
---disable-crypto, as it then doesn't get pulled in through push.h,
-leading to build errors like:
-
-options.c: In function ‘parse_http_proxy_fallback’:
-options.c:1474: error: dereferencing pointer to incomplete type
-options.c:1477: error: dereferencing pointer to incomplete type
-options.c:1478: error: dereferencing pointer to incomplete type
-
-Fix it by including forward.h
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- options.c |    1 +
- 1 file changed, 1 insertion(+)
-
-Index: openvpn-2.1.3/options.c
-===================================================================
---- openvpn-2.1.3.orig/options.c
-+++ openvpn-2.1.3/options.c
-@@ -29,6 +29,7 @@
- #include "syshead.h"
-+#include "forward.h"
- #include "buffer.h"
- #include "error.h"
- #include "common.h"
diff --git a/package/openvpn/openvpn-fix-build-with-disable-crypto.patch b/package/openvpn/openvpn-fix-build-with-disable-crypto.patch
new file mode 100644 (file)
index 0000000..5466558
--- /dev/null
@@ -0,0 +1,30 @@
+[PATCH] fix build with --disable-crypto
+
+options.c is missing the definition for struct context when built with
+--disable-crypto, as it then doesn't get pulled in through push.h,
+leading to build errors like:
+
+options.c: In function ‘parse_http_proxy_fallback’:
+options.c:1474: error: dereferencing pointer to incomplete type
+options.c:1477: error: dereferencing pointer to incomplete type
+options.c:1478: error: dereferencing pointer to incomplete type
+
+Fix it by including forward.h
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ options.c |    1 +
+ 1 file changed, 1 insertion(+)
+
+Index: openvpn-2.1.3/options.c
+===================================================================
+--- openvpn-2.1.3.orig/options.c
++++ openvpn-2.1.3/options.c
+@@ -29,6 +29,7 @@
+ #include "syshead.h"
++#include "forward.h"
+ #include "buffer.h"
+ #include "error.h"
+ #include "common.h"
diff --git a/package/openvpn/openvpn-fix-tmpdir.patch b/package/openvpn/openvpn-fix-tmpdir.patch
new file mode 100644 (file)
index 0000000..919d49b
--- /dev/null
@@ -0,0 +1,39 @@
+From b70d99fb617350b252c8bde2f1f2d81d3f5b7955 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Wed, 27 Apr 2011 18:43:50 +0200
+Subject: [PATCH] Fix compile issues when using --enable-small and --disable-ssl/--disable-crypto
+
+The tmp_dir string is required in the options struct regardless of options
+so spin it out of #if conditionals.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Acked-by: David Sommerseth <dazo@users.sourceforge.net>
+Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
+---
+ options.h |    3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/options.h b/options.h
+index a9c6a94..8a51502 100644
+--- a/options.h
++++ b/options.h
+@@ -369,6 +369,8 @@ struct options
+   struct plugin_option_list *plugin_list;
+ #endif
++  const char *tmp_dir;
++
+ #if P2MP
+ #if P2MP_SERVER
+@@ -409,7 +411,6 @@ struct options
+   const char *client_connect_script;
+   const char *client_disconnect_script;
+   const char *learn_address_script;
+-  const char *tmp_dir;
+   const char *client_config_dir;
+   bool ccd_exclusive;
+   bool disable;
+-- 
+1.7.0.1
+
index 89118b12b5554281a298f75f17e07389c8d7c1f3..27a9a553d495008f3527a2c78513861263b3c472 100644 (file)
@@ -4,15 +4,9 @@
 #
 #############################################################
 
-OPENVPN_VERSION = 2.1.4
+OPENVPN_VERSION = 2.2.0
 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small
-
-ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
-       OPENVPN_CONF_OPT += --enable-pthread
-else
-       OPENVPN_CONF_OPT += --disable-pthread
-endif
+OPENVPN_CONF_OPT = --enable-small --disable-plugins
 
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
        OPENVPN_DEPENDENCIES += lzo