package/libdrm: bump version to 2.4.101
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 3 Apr 2020 16:26:17 +0000 (18:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 4 Apr 2020 15:29:34 +0000 (17:29 +0200)
Removed patches applied upstream:
https://cgit.freedesktop.org/mesa/drm/commit/xf86drm.h?id=8c1185d22cb5ea09dea063bd4a0a4f8b64487919
https://cgit.freedesktop.org/mesa/drm/commit/xf86atomic.h?id=8c511950395ce496028bbc5ba30d9b9632690db6
https://cgit.freedesktop.org/mesa/drm/commit/meson.build?id=8de2696213d0f25a10a167b5fd6c312d6ce6a1af
https://cgit.freedesktop.org/mesa/drm/commit/tests/nouveau/threaded.c?id=cd77f114ca0073f609fc89d22390152945e73107

Renumbered remaining patches, use .xz tarball provided by upstream.
Removed md5 & sha1 hashes, not provided by upstream anymore.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
12 files changed:
package/libdrm/0001-Add-ARM-support-into-xf86drm.h.patch [deleted file]
package/libdrm/0001-meson.build-enable-static-build.patch [new file with mode: 0644]
package/libdrm/0002-tests-meson.build-disable-nouveau-tests-for-static-b.patch [new file with mode: 0644]
package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch [deleted file]
package/libdrm/0003-meson.build-fix-intel-atomics-detection.patch [deleted file]
package/libdrm/0003-tests-amdgpu-needs-atomic_ops.patch [new file with mode: 0644]
package/libdrm/0004-meson.build-enable-static-build.patch [deleted file]
package/libdrm/0005-tests-meson.build-disable-nouveau-tests-for-static-b.patch [deleted file]
package/libdrm/0006-tests-nouveau-threaded-adapt-ioctl-signature.patch [deleted file]
package/libdrm/0007-tests-amdgpu-needs-atomic_ops.patch [deleted file]
package/libdrm/libdrm.hash
package/libdrm/libdrm.mk

diff --git a/package/libdrm/0001-Add-ARM-support-into-xf86drm.h.patch b/package/libdrm/0001-Add-ARM-support-into-xf86drm.h.patch
deleted file mode 100644 (file)
index 3c00e9c..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-From 2e3dd0040e676530f7e735fab335ff449b9b3f4d Mon Sep 17 00:00:00 2001
-From: Lauren Post <lauren.post@freescale.com>
-Date: Tue, 22 Mar 2016 22:08:25 +0100
-Subject: [PATCH] Add ARM support into xf86drm.h
-
-This provides support for Xorg interface.  Without this the vivante
-samples will hang during close requiring a reboot
-
-[Adapted from yocto project]
-Upstream-Status: Pending
-Signed-off-by: Lauren Post <lauren.post@freescale.com>
-Signed-off-by: Evan Kotara <evan.kotara@freescale.com>
-[Thomas: change CAS code to only be used on ARMv6/ARMv7, and not
-ARMv4/ARMv5, which don't support ldrex/strex. If no CAS implementation
-is provided libdrm falls back to a system call for locking/unlocking.]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- xf86drm.h | 22 ++++++++++++++++++++++
- 1 file changed, 22 insertions(+)
-
-diff --git a/xf86drm.h b/xf86drm.h
-index 481d882..72341f6 100644
---- a/xf86drm.h
-+++ b/xf86drm.h
-@@ -469,6 +469,28 @@ do {      register unsigned int __old __asm("o0");                \
-               : "cr0", "memory");                     \
-       } while (0)
-+# elif defined (__ARM_ARCH_6__) || defined(__ARM_ARCH_6J__) \
-+      || defined (__ARM_ARCH_6Z__) || defined(__ARM_ARCH_6ZK__) \
-+      || defined (__ARM_ARCH_6K__) || defined(__ARM_ARCH_6T2__) \
-+      || defined (__ARM_ARCH_7__) || defined(__ARM_ARCH_7A__) \
-+      || defined(__ARM_ARCH_7R__) || defined(__ARM_ARCH_7M__) \
-+      || defined(__ARM_ARCH_7EM__)
-+       #undef DRM_DEV_MODE
-+       #define DRM_DEV_MODE     (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH)
-+
-+       #define DRM_CAS(lock,old,new,__ret)             \
-+       do {                                            \
-+               __asm__ __volatile__ (                  \
-+                       "1: ldrex %0, [%1]\n"           \
-+                       "   teq %0, %2\n"               \
-+                       "   ite eq\n"                   \
-+                       "   strexeq %0, %3, [%1]\n"     \
-+                       "   movne   %0, #1\n"           \
-+               : "=&r" (__ret)                         \
-+               : "r" (lock), "r" (old), "r" (new)      \
-+               : "cc","memory");                       \
-+       } while (0)
-+
- #endif /* architecture */
- #endif /* __GNUC__ >= 2 */
--- 
-2.6.4
-
diff --git a/package/libdrm/0001-meson.build-enable-static-build.patch b/package/libdrm/0001-meson.build-enable-static-build.patch
new file mode 100644 (file)
index 0000000..28da702
--- /dev/null
@@ -0,0 +1,169 @@
+From d58a32776e08e193c24f7bb192daf72b66fbe550 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Wed, 18 Jul 2018 21:35:18 +0200
+Subject: [PATCH] meson.build: enable static build
+
+Use meson library instead of shared_library to enable static build.
+
+Upstream suggested: https://lists.freedesktop.org/archives/dri-devel/2018-July/183886.html
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ amdgpu/meson.build    | 2 +-
+ etnaviv/meson.build   | 2 +-
+ exynos/meson.build    | 2 +-
+ freedreno/meson.build | 2 +-
+ intel/meson.build     | 2 +-
+ libkms/meson.build    | 2 +-
+ meson.build           | 2 +-
+ nouveau/meson.build   | 2 +-
+ omap/meson.build      | 2 +-
+ radeon/meson.build    | 2 +-
+ tegra/meson.build     | 2 +-
+ 11 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/amdgpu/meson.build b/amdgpu/meson.build
+index f39d7bf..1b4b0be 100644
+--- a/amdgpu/meson.build
++++ b/amdgpu/meson.build
+@@ -21,7 +21,7 @@
+
+ datadir_amdgpu = join_paths(get_option('prefix'), get_option('datadir'), 'libdrm')
+
+-libdrm_amdgpu = shared_library(
++libdrm_amdgpu = library(
+   'drm_amdgpu',
+   [
+     files(
+diff --git a/etnaviv/meson.build b/etnaviv/meson.build
+index ca2aa54..a0d994e 100644
+--- a/etnaviv/meson.build
++++ b/etnaviv/meson.build
+@@ -19,7 +19,7 @@
+ # SOFTWARE.
+
+
+-libdrm_etnaviv = shared_library(
++libdrm_etnaviv = library(
+   'drm_etnaviv',
+   [
+     files(
+diff --git a/exynos/meson.build b/exynos/meson.build
+index 30d3640..fd14f3a 100644
+--- a/exynos/meson.build
++++ b/exynos/meson.build
+@@ -18,7 +18,7 @@
+ # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ # SOFTWARE.
+
+-libdrm_exynos = shared_library(
++libdrm_exynos = library(
+   'drm_exynos',
+   [files('exynos_drm.c', 'exynos_fimg2d.c'), config_file],
+   c_args : warn_c_args,
+diff --git a/freedreno/meson.build b/freedreno/meson.build
+index 015b7fb..6c8a6a7 100644
+--- a/freedreno/meson.build
++++ b/freedreno/meson.build
+@@ -39,7 +39,7 @@ if with_freedreno_kgsl
+   )
+ endif
+
+-libdrm_freedreno = shared_library(
++libdrm_freedreno = library(
+   'drm_freedreno',
+   [files_freedreno, config_file],
+   c_args : warn_c_args,
+diff --git a/intel/meson.build b/intel/meson.build
+index 53c7fce..14cabd3 100644
+--- a/intel/meson.build
++++ b/intel/meson.build
+@@ -18,7 +18,7 @@
+ # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ # SOFTWARE.
+
+-libdrm_intel = shared_library(
++libdrm_intel = library(
+   'drm_intel',
+   [
+     files(
+diff --git a/libkms/meson.build b/libkms/meson.build
+index 86d1a4e..9d21e4c 100644
+--- a/libkms/meson.build
++++ b/libkms/meson.build
+@@ -41,7 +41,7 @@ if with_exynos
+   libkms_include += include_directories('../exynos')
+ endif
+
+-libkms = shared_library(
++libkms = library(
+   'kms',
+   [files_libkms, config_file],
+   c_args : warn_c_args,
+diff --git a/meson.build b/meson.build
+index 3c8afb6..7aa5f8c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -279,7 +279,7 @@ add_project_arguments('-include', 'config.h', language : 'c')
+ inc_root = include_directories('.')
+ inc_drm = include_directories('include/drm')
+
+-libdrm = shared_library(
++libdrm = library(
+   'drm',
+   [files(
+      'xf86drm.c', 'xf86drmHash.c', 'xf86drmRandom.c', 'xf86drmSL.c',
+diff --git a/nouveau/meson.build b/nouveau/meson.build
+index 51c9a71..acba048 100644
+--- a/nouveau/meson.build
++++ b/nouveau/meson.build
+@@ -19,7 +19,7 @@
+ # SOFTWARE.
+
+
+-libdrm_nouveau = shared_library(
++libdrm_nouveau = library(
+   'drm_nouveau',
+   [files( 'nouveau.c', 'pushbuf.c', 'bufctx.c', 'abi16.c'), config_file],
+   c_args : warn_c_args,
+diff --git a/omap/meson.build b/omap/meson.build
+index e57b8f5..6cffb99 100644
+--- a/omap/meson.build
++++ b/omap/meson.build
+@@ -18,7 +18,7 @@
+ # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ # SOFTWARE.
+
+-libdrm_omap = shared_library(
++libdrm_omap = library(
+   'drm_omap',
+   [files('omap_drm.c'), config_file],
+   include_directories : [inc_root, inc_drm],
+diff --git a/radeon/meson.build b/radeon/meson.build
+index b08c744..2f45ff7 100644
+--- a/radeon/meson.build
++++ b/radeon/meson.build
+@@ -19,7 +19,7 @@
+ # SOFTWARE.
+
+
+-libdrm_radeon = shared_library(
++libdrm_radeon = library(
+   'drm_radeon',
+   [
+     files(
+diff --git a/tegra/meson.build b/tegra/meson.build
+index 1f5c74b..8d0cfa9 100644
+--- a/tegra/meson.build
++++ b/tegra/meson.build
+@@ -18,7 +18,7 @@
+ # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ # SOFTWARE.
+
+-libdrm_tegra = shared_library(
++libdrm_tegra = library(
+   'drm_tegra',
+   [files('tegra.c'), config_file],
+   include_directories : [inc_root, inc_drm],
+--
+2.18.0
+
diff --git a/package/libdrm/0002-tests-meson.build-disable-nouveau-tests-for-static-b.patch b/package/libdrm/0002-tests-meson.build-disable-nouveau-tests-for-static-b.patch
new file mode 100644 (file)
index 0000000..e2e18e1
--- /dev/null
@@ -0,0 +1,43 @@
+From c9036706b9f724f09ac6288f82b53f2e76264ec7 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Mon, 25 Nov 2019 15:59:15 +0100
+Subject: [PATCH] tests/meson.build: disable nouveau tests for static build
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+Notes:
+
+  - the existing test/check for static build in meson.build does not
+    catch this case because e.g. the buildroot toolchain
+    br-arm-full-static-2019.05.1 provides an empty libdl.a
+
+  169 # Among others FreeBSD does not have a separate dl library.
+  170 if not cc.has_function('dlsym')
+  171   dep_dl = cc.find_library('dl', required : with_nouveau)
+  172 else
+  173   dep_dl = []
+  174 endif
+---
+ tests/meson.build | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 6c8ddd9..f7cb5f0 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -44,8 +44,11 @@ endif
+ if with_etnaviv
+   subdir('etnaviv')
+ endif
++lib_type = get_option('default_library')
+ if with_nouveau
+-  subdir('nouveau')
++  if lib_type != 'static'
++    subdir('nouveau')
++  endif
+ endif
+ drmsl = executable(
+-- 
+2.24.0
+
diff --git a/package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch b/package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch
deleted file mode 100644 (file)
index ff920fb..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 7384f79f69fdb7b691cc5b0c28c301b3fe8b633e Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Thu, 26 May 2016 10:46:57 +0200
-Subject: [PATCH] xf86atomic: require CAS support in libatomic_ops
-
-Since AO_compare_and_swap_full() is used by libdrm, AO_REQUIRE_CAS
-must be defined before including <atomic_ops.h> so that we are sure
-that CAS support will be provided. This is necessary to make sure that
-the AO_compare_and_swap_full() function will be provided on all
-architectures, including the ones that don't have built-in CAS support
-such as SPARCv8.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- xf86atomic.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/xf86atomic.h b/xf86atomic.h
-index 922b37d..d7017a5 100644
---- a/xf86atomic.h
-+++ b/xf86atomic.h
-@@ -58,6 +58,7 @@ typedef struct {
- #endif
- #if HAVE_LIB_ATOMIC_OPS
-+#define AO_REQUIRE_CAS
- #include <atomic_ops.h>
- #define HAS_ATOMIC_OPS 1
--- 
-2.7.4
-
diff --git a/package/libdrm/0003-meson.build-fix-intel-atomics-detection.patch b/package/libdrm/0003-meson.build-fix-intel-atomics-detection.patch
deleted file mode 100644 (file)
index 5d7cd5e..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From 00f6ac3c24f36fa07fa93f4a89ee873edf125098 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Mon, 16 Jul 2018 23:01:40 +0200
-Subject: [PATCH] meson.build: fix intel atomics detection
-
-Use the stronger compiler.link() test (instead of the weaker
-compiler.compile()) to fix the intel atomics detection.
-
-Fixes false positive in case of sparc compile (buildroot toolchain).
-
-Upstream suggested: https://lists.freedesktop.org/archives/dri-devel/2018-July/183885.html
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- meson.build | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 9b443a5..3c8afb6 100644
---- a/meson.build
-+++ b/meson.build
-@@ -49,9 +49,10 @@ intel_atomics = false
- lib_atomics = false
-
- dep_atomic_ops = dependency('atomic_ops', required : false)
--if cc.compiles('''
-+if cc.links('''
-     int atomic_add(int *i) { return __sync_add_and_fetch (i, 1); }
-     int atomic_cmpxchg(int *i, int j, int k) { return __sync_val_compare_and_swap (i, j, k); }
-+    int main() { }
-     ''',
-     name : 'Intel Atomics')
-   intel_atomics = true
---
-2.18.0
-
diff --git a/package/libdrm/0003-tests-amdgpu-needs-atomic_ops.patch b/package/libdrm/0003-tests-amdgpu-needs-atomic_ops.patch
new file mode 100644 (file)
index 0000000..9c06675
--- /dev/null
@@ -0,0 +1,27 @@
+From f0adb08424e624aeee340291343281256b7a98e8 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Sat, 7 Mar 2020 12:23:09 +0100
+Subject: [PATCH] tests/amdgpu: needs atomic_ops
+
+[Upstream: https://gitlab.freedesktop.org/mesa/drm/-/merge_requests/50]
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ tests/amdgpu/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/amdgpu/meson.build b/tests/amdgpu/meson.build
+index 1726cb43..4dfa5c83 100644
+--- a/tests/amdgpu/meson.build
++++ b/tests/amdgpu/meson.build
+@@ -26,7 +26,7 @@ if dep_cunit.found()
+       'vce_tests.c', 'uvd_enc_tests.c', 'vcn_tests.c', 'deadlock_tests.c',
+       'vm_tests.c', 'ras_tests.c', 'syncobj_tests.c',
+     ),
+-    dependencies : [dep_cunit, dep_threads],
++    dependencies : [dep_cunit, dep_threads, dep_atomic_ops],
+     include_directories : [inc_root, inc_drm, include_directories('../../amdgpu')],
+     link_with : [libdrm, libdrm_amdgpu],
+     install : with_install_tests,
+-- 
+2.25.1
+
diff --git a/package/libdrm/0004-meson.build-enable-static-build.patch b/package/libdrm/0004-meson.build-enable-static-build.patch
deleted file mode 100644 (file)
index 28da702..0000000
+++ /dev/null
@@ -1,169 +0,0 @@
-From d58a32776e08e193c24f7bb192daf72b66fbe550 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Wed, 18 Jul 2018 21:35:18 +0200
-Subject: [PATCH] meson.build: enable static build
-
-Use meson library instead of shared_library to enable static build.
-
-Upstream suggested: https://lists.freedesktop.org/archives/dri-devel/2018-July/183886.html
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- amdgpu/meson.build    | 2 +-
- etnaviv/meson.build   | 2 +-
- exynos/meson.build    | 2 +-
- freedreno/meson.build | 2 +-
- intel/meson.build     | 2 +-
- libkms/meson.build    | 2 +-
- meson.build           | 2 +-
- nouveau/meson.build   | 2 +-
- omap/meson.build      | 2 +-
- radeon/meson.build    | 2 +-
- tegra/meson.build     | 2 +-
- 11 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/amdgpu/meson.build b/amdgpu/meson.build
-index f39d7bf..1b4b0be 100644
---- a/amdgpu/meson.build
-+++ b/amdgpu/meson.build
-@@ -21,7 +21,7 @@
-
- datadir_amdgpu = join_paths(get_option('prefix'), get_option('datadir'), 'libdrm')
-
--libdrm_amdgpu = shared_library(
-+libdrm_amdgpu = library(
-   'drm_amdgpu',
-   [
-     files(
-diff --git a/etnaviv/meson.build b/etnaviv/meson.build
-index ca2aa54..a0d994e 100644
---- a/etnaviv/meson.build
-+++ b/etnaviv/meson.build
-@@ -19,7 +19,7 @@
- # SOFTWARE.
-
-
--libdrm_etnaviv = shared_library(
-+libdrm_etnaviv = library(
-   'drm_etnaviv',
-   [
-     files(
-diff --git a/exynos/meson.build b/exynos/meson.build
-index 30d3640..fd14f3a 100644
---- a/exynos/meson.build
-+++ b/exynos/meson.build
-@@ -18,7 +18,7 @@
- # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- # SOFTWARE.
-
--libdrm_exynos = shared_library(
-+libdrm_exynos = library(
-   'drm_exynos',
-   [files('exynos_drm.c', 'exynos_fimg2d.c'), config_file],
-   c_args : warn_c_args,
-diff --git a/freedreno/meson.build b/freedreno/meson.build
-index 015b7fb..6c8a6a7 100644
---- a/freedreno/meson.build
-+++ b/freedreno/meson.build
-@@ -39,7 +39,7 @@ if with_freedreno_kgsl
-   )
- endif
-
--libdrm_freedreno = shared_library(
-+libdrm_freedreno = library(
-   'drm_freedreno',
-   [files_freedreno, config_file],
-   c_args : warn_c_args,
-diff --git a/intel/meson.build b/intel/meson.build
-index 53c7fce..14cabd3 100644
---- a/intel/meson.build
-+++ b/intel/meson.build
-@@ -18,7 +18,7 @@
- # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- # SOFTWARE.
-
--libdrm_intel = shared_library(
-+libdrm_intel = library(
-   'drm_intel',
-   [
-     files(
-diff --git a/libkms/meson.build b/libkms/meson.build
-index 86d1a4e..9d21e4c 100644
---- a/libkms/meson.build
-+++ b/libkms/meson.build
-@@ -41,7 +41,7 @@ if with_exynos
-   libkms_include += include_directories('../exynos')
- endif
-
--libkms = shared_library(
-+libkms = library(
-   'kms',
-   [files_libkms, config_file],
-   c_args : warn_c_args,
-diff --git a/meson.build b/meson.build
-index 3c8afb6..7aa5f8c 100644
---- a/meson.build
-+++ b/meson.build
-@@ -279,7 +279,7 @@ add_project_arguments('-include', 'config.h', language : 'c')
- inc_root = include_directories('.')
- inc_drm = include_directories('include/drm')
-
--libdrm = shared_library(
-+libdrm = library(
-   'drm',
-   [files(
-      'xf86drm.c', 'xf86drmHash.c', 'xf86drmRandom.c', 'xf86drmSL.c',
-diff --git a/nouveau/meson.build b/nouveau/meson.build
-index 51c9a71..acba048 100644
---- a/nouveau/meson.build
-+++ b/nouveau/meson.build
-@@ -19,7 +19,7 @@
- # SOFTWARE.
-
-
--libdrm_nouveau = shared_library(
-+libdrm_nouveau = library(
-   'drm_nouveau',
-   [files( 'nouveau.c', 'pushbuf.c', 'bufctx.c', 'abi16.c'), config_file],
-   c_args : warn_c_args,
-diff --git a/omap/meson.build b/omap/meson.build
-index e57b8f5..6cffb99 100644
---- a/omap/meson.build
-+++ b/omap/meson.build
-@@ -18,7 +18,7 @@
- # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- # SOFTWARE.
-
--libdrm_omap = shared_library(
-+libdrm_omap = library(
-   'drm_omap',
-   [files('omap_drm.c'), config_file],
-   include_directories : [inc_root, inc_drm],
-diff --git a/radeon/meson.build b/radeon/meson.build
-index b08c744..2f45ff7 100644
---- a/radeon/meson.build
-+++ b/radeon/meson.build
-@@ -19,7 +19,7 @@
- # SOFTWARE.
-
-
--libdrm_radeon = shared_library(
-+libdrm_radeon = library(
-   'drm_radeon',
-   [
-     files(
-diff --git a/tegra/meson.build b/tegra/meson.build
-index 1f5c74b..8d0cfa9 100644
---- a/tegra/meson.build
-+++ b/tegra/meson.build
-@@ -18,7 +18,7 @@
- # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- # SOFTWARE.
-
--libdrm_tegra = shared_library(
-+libdrm_tegra = library(
-   'drm_tegra',
-   [files('tegra.c'), config_file],
-   include_directories : [inc_root, inc_drm],
---
-2.18.0
-
diff --git a/package/libdrm/0005-tests-meson.build-disable-nouveau-tests-for-static-b.patch b/package/libdrm/0005-tests-meson.build-disable-nouveau-tests-for-static-b.patch
deleted file mode 100644 (file)
index e2e18e1..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From c9036706b9f724f09ac6288f82b53f2e76264ec7 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Mon, 25 Nov 2019 15:59:15 +0100
-Subject: [PATCH] tests/meson.build: disable nouveau tests for static build
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
-Notes:
-
-  - the existing test/check for static build in meson.build does not
-    catch this case because e.g. the buildroot toolchain
-    br-arm-full-static-2019.05.1 provides an empty libdl.a
-
-  169 # Among others FreeBSD does not have a separate dl library.
-  170 if not cc.has_function('dlsym')
-  171   dep_dl = cc.find_library('dl', required : with_nouveau)
-  172 else
-  173   dep_dl = []
-  174 endif
----
- tests/meson.build | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/tests/meson.build b/tests/meson.build
-index 6c8ddd9..f7cb5f0 100644
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -44,8 +44,11 @@ endif
- if with_etnaviv
-   subdir('etnaviv')
- endif
-+lib_type = get_option('default_library')
- if with_nouveau
--  subdir('nouveau')
-+  if lib_type != 'static'
-+    subdir('nouveau')
-+  endif
- endif
- drmsl = executable(
--- 
-2.24.0
-
diff --git a/package/libdrm/0006-tests-nouveau-threaded-adapt-ioctl-signature.patch b/package/libdrm/0006-tests-nouveau-threaded-adapt-ioctl-signature.patch
deleted file mode 100644 (file)
index 8084570..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 6c7b305869b941e52cb846cbed5e4a5c85d035d9 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Mon, 18 Jun 2018 15:07:03 +0100
-Subject: [PATCH] tests/nouveau/threaded: adapt ioctl signature
-
-POSIX says ioctl() has the signature (int, int, ...) but glibc has decided to
-use (int, unsigned long int, ...) instead.
-
-Use a #ifdef to adapt the replacement function as appropriate.
-
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-[Taken from https://raw.githubusercontent.com/openembedded/openembedded-core/master/meta/recipes-graphics/drm/libdrm/musl-ioctl.patch]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- tests/nouveau/threaded.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/tests/nouveau/threaded.c b/tests/nouveau/threaded.c
-index 3669bcd..e1c27c0 100644
---- a/tests/nouveau/threaded.c
-+++ b/tests/nouveau/threaded.c
-@@ -36,7 +36,11 @@ static int failed;
- static int import_fd;
-+#ifdef __GLIBC__
- int ioctl(int fd, unsigned long request, ...)
-+#else
-+int ioctl(int fd, int request, ...)
-+#endif
- {
-       va_list va;
-       int ret;
--- 
-2.24.0
-
diff --git a/package/libdrm/0007-tests-amdgpu-needs-atomic_ops.patch b/package/libdrm/0007-tests-amdgpu-needs-atomic_ops.patch
deleted file mode 100644 (file)
index 9c06675..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From f0adb08424e624aeee340291343281256b7a98e8 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Sat, 7 Mar 2020 12:23:09 +0100
-Subject: [PATCH] tests/amdgpu: needs atomic_ops
-
-[Upstream: https://gitlab.freedesktop.org/mesa/drm/-/merge_requests/50]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- tests/amdgpu/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/amdgpu/meson.build b/tests/amdgpu/meson.build
-index 1726cb43..4dfa5c83 100644
---- a/tests/amdgpu/meson.build
-+++ b/tests/amdgpu/meson.build
-@@ -26,7 +26,7 @@ if dep_cunit.found()
-       'vce_tests.c', 'uvd_enc_tests.c', 'vcn_tests.c', 'deadlock_tests.c',
-       'vm_tests.c', 'ras_tests.c', 'syncobj_tests.c',
-     ),
--    dependencies : [dep_cunit, dep_threads],
-+    dependencies : [dep_cunit, dep_threads, dep_atomic_ops],
-     include_directories : [inc_root, inc_drm, include_directories('../../amdgpu')],
-     link_with : [libdrm, libdrm_amdgpu],
-     install : with_install_tests,
--- 
-2.25.1
-
index 7b50e66a919494a1aee0134f2cbaba573422322d..4c9c4c4fedefe33789e6eb64befbe945b2b809c0 100644 (file)
@@ -1,5 +1,3 @@
-# From https://lists.freedesktop.org/archives/dri-devel/2019-October/240455.html
-md5 f47bc87e28198ba527e6b44ffdd62f65  libdrm-2.4.100.tar.bz2
-sha1 9f526909aba08b5658cfba3f7fde9385cad6f3b5  libdrm-2.4.100.tar.bz2
-sha256 c77cc828186c9ceec3e56ae202b43ee99eb932b4a87255038a80e8a1060d0a5d  libdrm-2.4.100.tar.bz2
-sha512 4d3a5556e650872944af52f49de395e0ce8ac9ac58530e39a34413e94dc56c231ee71b8b8de9fb944263515a922b3ebbf7ddfebeaaa91543c2604f9bcf561247  libdrm-2.4.100.tar.bz2
+# From https://lists.freedesktop.org/archives/dri-devel/2020-April/261067.html
+sha256 ddf31baa8e49473624860bd166ce654dc349873f7a6c7b3305964249315c78a7  libdrm-2.4.101.tar.xz
+sha512 658cfc6f478b674b77b4613e1af9ce8f4fd2ace8a18e75729de254d14b7c1f5d67d4bfdb58744aea74abca0f6521326225f4156bd5cbeeed79ca3e025f657e8c  libdrm-2.4.101.tar.xz
index f7c9205744cbfeeb7087436e4284c54deccb18c5..4217fcc84ce663da2d2a471243c4807563d9d159 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBDRM_VERSION = 2.4.100
-LIBDRM_SOURCE = libdrm-$(LIBDRM_VERSION).tar.bz2
+LIBDRM_VERSION = 2.4.101
+LIBDRM_SOURCE = libdrm-$(LIBDRM_VERSION).tar.xz
 LIBDRM_SITE = https://dri.freedesktop.org/libdrm
 LIBDRM_LICENSE = MIT
 LIBDRM_INSTALL_STAGING = YES