busybox: remove quirk for old unsupported versions
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Wed, 29 Jun 2011 13:46:18 +0000 (15:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Jul 2011 06:13:48 +0000 (08:13 +0200)
This code is no longer useful, since the oldest version supported by
Builroot is 1.16.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk

index b77880ca7ddb739bec6c1dd2c036e1bf23117584..034801ec5e05eb35d82f12085dc0ad8fb6a7cfc3 100644 (file)
@@ -49,17 +49,6 @@ define BUSYBOX_SET_SYSKLOGD
 endef
 endif
 
-# id applet breaks on >=1.13.0 with old uclibc unless the bb pwd routines are used
-ifeq ($(BR2_BUSYBOX_VERSION_1_13_X)$(BR2_BUSYBOX_VERSION_1_14_X)$(BR2_UCLIBC_VERSION_0_9_29),yy)
-define BUSYBOX_SET_BB_PWD
-       if grep -q 'CONFIG_ID=y' $(BUSYBOX_BUILD_CONFIG); \
-       then \
-               echo 'warning: CONFIG_ID needs BB_PWD_GRP with old uclibc, enabling' >&2;\
-               $(SED) "s/^.*CONFIG_USE_BB_PWD_GRP.*/CONFIG_USE_BB_PWD_GRP=y/;" $(BUSYBOX_BUILD_CONFIG); \
-       fi
-endef
-endif
-
 ifeq ($(BR2_LARGEFILE),y)
 define BUSYBOX_SET_LARGEFILE
        $(call KCONFIG_ENABLE_OPT,CONFIG_LFS,$(BUSYBOX_BUILD_CONFIG))