pkg-kconfig: declare phony targets as such
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Apr 2015 16:37:45 +0000 (18:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Apr 2015 08:12:24 +0000 (10:12 +0200)
Just like the previous commit did for the pkg-generic infrastructure,
this commit improves the pkg-kconfig infrastructure to declare its
custom <pkg>-<something> targets as PHONY.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/pkg-kconfig.mk

index fd9f19d949bd1346b710f57dc8d411ba20bfe42b..8361064e2bd26e2b6c3e21d5202f117297a83bab 100644 (file)
@@ -100,6 +100,12 @@ $(1)-update-defconfig: $(1)-savedefconfig
 
 endif # package enabled
 
+.PHONY: \
+       $(1)-update-config \
+       $(1)-update-defconfig \
+       $(1)-savedefconfig \
+       $$(addprefix $(1)-,$$($(2)_KCONFIG_EDITORS))
+
 endef # inner-kconfig-package
 
 ################################################################################