pkg-stats: support <pkg>_LICENSE = lines with spaces
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Aug 2012 09:44:52 +0000 (11:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Aug 2012 09:44:52 +0000 (11:44 +0200)
For alignement reasons, we sometimes add spaces between <pkg>_LICENSE
and the equal sign. Take this into account in pkg-stats.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
support/scripts/pkg-stats

index de73eeb27087c334fded00b0541b1ed1526cea2e..a07af555e9155460a580172f589fb4342d118435 100755 (executable)
@@ -155,7 +155,7 @@ for i in $(find boot/ linux/ package/ -name '*.mk' | sort) ; do
        generic_packages=$(($generic_packages+1))
     fi
 
-    if grep -qE "^${pkgvariable}_LICENSE =" $i ; then
+    if grep -qE "^${pkgvariable}_LICENSE[ ]*=" $i ; then
        packages_with_license=$(($packages_with_license+1))
        license=1
     else