package/boost: Add Kconfig option for new module metaparse
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 4 Jun 2016 13:17:37 +0000 (15:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Jun 2016 05:56:35 +0000 (07:56 +0200)
The module description can be found in the release notes of v1.61.0:
http://www.boost.org/users/history/version_1_61_0.html

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index 4cfd44eb941a469d3bcf6dd97f8501565b86a58e..fae4b5fed7e1540e69d48177796959e9445e1268 100644 (file)
@@ -114,6 +114,9 @@ comment "boost-log needs a toolchain w/ NPTL"
 config BR2_PACKAGE_BOOST_MATH
        bool "boost-math"
 
+config BR2_PACKAGE_BOOST_METAPARSE
+       bool "boost-metaparse"
+
 config BR2_PACKAGE_BOOST_MPI
        bool "boost-mpi"
 
index e6459b9a3a3d5c5a19260ddf3a3d22810a771cca..fc8926509b4a50a5cdc00844bf5a43a972e10fbc 100644 (file)
@@ -35,6 +35,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_IOSTREAMS),,iostreams)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_METAPARSE),,metaparse)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PYTHON),,python)