php-*: get tarball from sources.buildroot.net
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Aug 2014 19:10:57 +0000 (21:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Aug 2014 19:13:47 +0000 (21:13 +0200)
pecl.php.net seems to have a database issue and returns a html page instead
of the tarball.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php-imagick/php-imagick.mk
package/php-memcached/php-memcached.mk
package/php-ssh2/php-ssh2.mk
package/php-yaml/php-yaml.mk
package/php-zmq/php-zmq.mk

index 148d519495d025b137182249dfbee2bc97d6674b..05340e398af0fee50b7de5220992735668ca7d05 100644 (file)
@@ -6,7 +6,8 @@
 
 PHP_IMAGICK_VERSION = 3.1.2
 PHP_IMAGICK_SOURCE = imagick-$(PHP_IMAGICK_VERSION).tgz
-PHP_IMAGICK_SITE = http://pecl.php.net/get
+# pecl.php.net returns html with db connect failed
+PHP_IMAGICK_SITE = http://sources.buildroot.net
 PHP_IMAGICK_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
        --with-imagick=$(STAGING_DIR)/usr
 # phpize does the autoconf magic
index b9cc115617c3e1326c0f3aaa6eaafd9c0932af7e..1fa648109d52cb5ae8047163e7f3d0003b7978aa 100644 (file)
@@ -6,7 +6,8 @@
 
 PHP_MEMCACHED_VERSION = 2.2.0
 PHP_MEMCACHED_SOURCE = memcached-$(PHP_MEMCACHED_VERSION).tgz
-PHP_MEMCACHED_SITE = http://pecl.php.net/get
+# pecl.php.net returns html with db connect failed
+PHP_MEMCACHED_SITE = http://sources.buildroot.net
 PHP_MEMCACHED_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
        --disable-memcached-sasl \
        --with-libmemcached-dir=$(STAGING_DIR)/usr \
index f2067a4dfa5fe3d636459c8f57714872d5727b3e..d1e830449cac873503248e7f04b14ff4b90822cf 100644 (file)
@@ -6,7 +6,8 @@
 
 PHP_SSH2_VERSION = 0.12
 PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
-PHP_SSH2_SITE = http://pecl.php.net/get
+# pecl.php.net returns html with db connect failed
+PHP_SSH2_SITE = http://sources.buildroot.net
 PHP_SSH2_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
        --with-ssh2=$(STAGING_DIR)/usr
 # phpize does the autoconf magic
index a53e0126b58247d7c3554bfb20729a3ca2dee5bf..053efc4e6e049150a8d01a2e52ff7934ddd6a24a 100644 (file)
@@ -6,7 +6,8 @@
 
 PHP_YAML_VERSION = 1.1.1
 PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
-PHP_YAML_SITE = http://pecl.php.net/get
+# pecl.php.net returns html with db connect failed
+PHP_YAML_SITE = http://sources.buildroot.net
 PHP_YAML_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
        --with-yaml=$(STAGING_DIR)/usr
 # phpize does the autoconf magic
index 2b48a637f897452a7cc1a7a0922e212b32ac562d..19916357f86c4814017f7bc5bb3d08e1912f3333 100644 (file)
@@ -6,7 +6,8 @@
 
 PHP_ZMQ_VERSION = 1.1.2
 PHP_ZMQ_SOURCE = zmq-$(PHP_ZMQ_VERSION).tgz
-PHP_ZMQ_SITE = http://pecl.php.net/get
+# pecl.php.net returns html with db connect failed
+PHP_ZMQ_SITE = http://sources.buildroot.net
 # phpize does the autoconf magic
 PHP_ZMQ_DEPENDENCIES = php zeromq host-autoconf host-pkgconf
 PHP_ZMQ_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config