xterm: x-includes and x-libraries must be set for cross-compiling
authorkyak <bas@bmail.ru>
Mon, 27 Jul 2015 14:46:49 +0000 (17:46 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2015 20:53:26 +0000 (22:53 +0200)
These flags need to be set so that the configure script would
correctly use libICE from cross-toolchain rather than from host.

This fix is similar to "package/efl/libevas: x-includes and x-libraries
must be set for cross-compiling" done by Romain Naour on libecore.

Signed-off-by: Mikhail Peselnik <bas@bmail.ru>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xterm/xterm.mk

index 56f692dd219d38b11e27d066201fbf8bd27b3977..778b40cbd836e22ed3b576384810e5ccb5d96950 100644 (file)
@@ -10,6 +10,8 @@ XTERM_SITE = ftp://invisible-island.net/xterm
 XTERM_DEPENDENCIES = ncurses xlib_libXaw
 XTERM_LICENSE = MIT
 XTERM_LICENSE_FILES = version.c
-XTERM_CONF_OPTS = --enable-256-color
+XTERM_CONF_OPTS = --enable-256-color \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
 
 $(eval $(autotools-package))