botan: fix static build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 16 Sep 2018 09:49:55 +0000 (11:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Sep 2018 13:53:54 +0000 (15:53 +0200)
Don't pass crs in AR as it is now done by botan, see:
https://github.com/randombit/botan/commit/a9e4eede3942748234d705cc616ecc106e3767a6

Fixes:
 - http://autobuild.buildroot.org/results/5c15fe739cb1b6079dacf234699ee048924b74fb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index 4788617d4ac8e5806b2d5efbe1f85cb9172e7a1c..59aa1f0803ee384bbacaf56e016f3594d33d7249 100644 (file)
@@ -87,7 +87,7 @@ define BOTAN_CONFIGURE_CMDS
 endef
 
 define BOTAN_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) AR="$(TARGET_AR) crs"
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) AR="$(TARGET_AR)"
 endef
 
 define BOTAN_INSTALL_STAGING_CMDS