uclibc: update to 1.0.15
authorWaldemar Brodkorb <wbx@openadk.org>
Wed, 1 Jun 2016 18:40:25 +0000 (20:40 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 1 Jun 2016 19:23:29 +0000 (21:23 +0200)
The Linuxthreads support got reorganized.
LT.new is removed, LT.old is the default for
Linuxthreads.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/uclibc/Config.in
package/uclibc/uclibc.hash
package/uclibc/uclibc.mk

index 9bb9b623c2edaba2ed52e75c9b73fe7b2876443f..b73603b7c200fb8ab5690bc6732feae587091195 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.08"
 
+config BR2_PTHREADS_OLD
+       bool "linuxthreads (stable/old)"
+       select BR2_LEGACY
+       help
+         Linuxthreads have been reworked, BR2_PTHREADS_OLD is now
+         BR2_PTHREADS and the old BR2_PTHREADS - LT.new got removed.
+
 config BR2_BINUTILS_VERSION_2_23_X
        bool "binutils 2.23 removed"
        select BR2_LEGACY
index efa84e9e85efe775b7a1dfdd1fff985a2b58124f..1aad9a0b4a520a89fe2bdb771d63a6406ac81b6a 100644 (file)
@@ -48,7 +48,7 @@ config BR2_TOOLCHAIN_BUILDROOT_LOCALE
 choice
        prompt "Thread library implementation"
        default BR2_PTHREADS_NATIVE
-       default BR2_PTHREADS_OLD if !BR2_USE_MMU
+       default BR2_PTHREADS if !BR2_USE_MMU
        help
          Use this option to select the thread library implementation
          that should be used in your toolchain.
@@ -59,11 +59,6 @@ choice
        config BR2_PTHREADS
                bool "linuxthreads"
                select BR2_TOOLCHAIN_HAS_THREADS
-               depends on BR2_m68k
-
-       config BR2_PTHREADS_OLD
-               bool "linuxthreads (stable/old)"
-               select BR2_TOOLCHAIN_HAS_THREADS
                depends on BR2_m68k || BR2_arm || BR2_armeb || BR2_xtensa
 
        config BR2_PTHREADS_NATIVE
@@ -76,7 +71,7 @@ endchoice
 
 config BR2_PTHREAD_DEBUG
        bool "Thread library debugging"
-       depends on BR2_PTHREADS || BR2_PTHREADS_OLD || BR2_PTHREADS_NATIVE
+       depends on BR2_PTHREADS || BR2_PTHREADS_NATIVE
        select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
        help
          Build the thread library with debugging enabled.
index eccce349514336269cc8ff102897cdce7ba10b6a..01a6b80dc72e52c19f05dcd62f02fb12879b2ca0 100644 (file)
@@ -1,2 +1,2 @@
 # From http://www.uclibc-ng.org/
-sha256  3c63d9f8c8b98b65fa5c4040d1c8ab1b36e99a16e1093810cedad51ac15c9a9e        uClibc-ng-1.0.14.tar.xz
+sha256  0f62f35217d9a0b5eb3810dd6de16ab3dd4323f3224c6b95423250ac1e19ee49        uClibc-ng-1.0.15.tar.xz
index 1e128968848f833049dca15cf6e3a5787f6e341e..cf343a46de3efa32c9da51508a1a5625f41a3830 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-UCLIBC_VERSION = 1.0.14
+UCLIBC_VERSION = 1.0.15
 UCLIBC_SOURCE = uClibc-ng-$(UCLIBC_VERSION).tar.xz
 UCLIBC_SITE = http://downloads.uclibc-ng.org/releases/$(UCLIBC_VERSION)
 UCLIBC_LICENSE = LGPLv2.1+
@@ -328,29 +328,19 @@ endif
 ifeq ($(BR2_PTHREADS_NONE),y)
 define UCLIBC_THREAD_CONFIG
        $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_THREADS,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS_OLD,$(@D)/.config)
+       $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_LINUXTHREADS,$(@D)/.config)
        $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_THREADS_NATIVE,$(@D)/.config)
 endef
 else ifeq ($(BR2_PTHREADS),y)
 define UCLIBC_THREAD_CONFIG
        $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_THREADS,$(@D)/.config)
-       $(call KCONFIG_ENABLE_OPT,LINUXTHREADS_NEW,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS_OLD,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_THREADS_NATIVE,$(@D)/.config)
-endef
-else ifeq ($(BR2_PTHREADS_OLD),y)
-define UCLIBC_THREAD_CONFIG
-       $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_THREADS,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS_NEW,$(@D)/.config)
-       $(call KCONFIG_ENABLE_OPT,LINUXTHREADS_OLD,$(@D)/.config)
+       $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_LINUXTHREADS,$(@D)/.config)
        $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_THREADS_NATIVE,$(@D)/.config)
 endef
 else ifeq ($(BR2_PTHREADS_NATIVE),y)
 define UCLIBC_THREAD_CONFIG
        $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_THREADS,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS_NEW,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,LINUXTHREADS_OLD,$(@D)/.config)
+       $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_LINUXTHREADS,$(@D)/.config)
        $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_THREADS_NATIVE,$(@D)/.config)
 endef
 endif