package/kodi-adsp-freesurround: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 22:09:32 +0000 (23:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 15:01:01 +0000 (16:01 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi-adsp-freesurround/Config.in [new file with mode: 0644]
package/kodi-adsp-freesurround/kodi-adsp-freesurround.hash [new file with mode: 0644]
package/kodi-adsp-freesurround/kodi-adsp-freesurround.mk [new file with mode: 0644]
package/kodi/Config.in

diff --git a/package/kodi-adsp-freesurround/Config.in b/package/kodi-adsp-freesurround/Config.in
new file mode 100644 (file)
index 0000000..80aadf1
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_KODI_ADSP_FREESURROUND
+       bool "kodi-adsp-freesurround"
+       select BR2_PACKAGE_LIBPLATFORM
+       select BR2_PACKAGE_KODI_PLATFORM
+       help
+         FreeSurround is meant to be the KODI equivalent of your
+         hi-fi receiver's Dolby ProLogic II button. It's purpose is
+         to decode surround information from your stereo music and to
+         produce multichannel output from it.
+
+         https://github.com/kodi-adsp/adsp.freesurround
diff --git a/package/kodi-adsp-freesurround/kodi-adsp-freesurround.hash b/package/kodi-adsp-freesurround/kodi-adsp-freesurround.hash
new file mode 100644 (file)
index 0000000..f23717f
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 652c32d0c4b61343cbed13b6edd1ab4ad35280240a0ddb386f04adaa46986e7f kodi-adsp-freesurround-08b691d3d9a0382d2f6f789a31614fb02512036c.tar.gz
diff --git a/package/kodi-adsp-freesurround/kodi-adsp-freesurround.mk b/package/kodi-adsp-freesurround/kodi-adsp-freesurround.mk
new file mode 100644 (file)
index 0000000..49cf673
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# kodi-adsp-freesurround
+#
+################################################################################
+
+KODI_ADSP_FREESURROUND_VERSION = 08b691d3d9a0382d2f6f789a31614fb02512036c
+KODI_ADSP_FREESURROUND_SITE = $(call github,kodi-adsp,adsp.freesurround,$(KODI_ADSP_FREESURROUND_VERSION))
+KODI_ADSP_FREESURROUND_LICENSE = GPLv3+
+KODI_ADSP_FREESURROUND_LICENSE_FILES = LICENSE.md
+KODI_ADSP_FREESURROUND_DEPENDENCIES = libplatform kodi-platform
+
+$(eval $(cmake-package))
index 91486b912d7e7b626940227a91151caa5d0135f9..d7277646889e6cbe49265fa07122c3b5314bcc5a 100644 (file)
@@ -238,6 +238,10 @@ menu "Audio decoder addons"
        source "package/kodi-audiodecoder-vgmstream/Config.in"
 endmenu
 
+menu "Audio DSP addons"
+       source "package/kodi-adsp-freesurround/Config.in"
+endmenu
+
 menu "Audio encoder addons"
        source "package/kodi-audioencoder-flac/Config.in"
        source "package/kodi-audioencoder-lame/Config.in"